1. AC Question's Avatar
    Kies recognises my S3 but when I select the back up option it just keeps saying files being loaded to back up but it DOESN'T backup or move from that point. What can I do? I have tried deselecting items one at a time to see if it is particular item it CANNOT back up but to no avail same result.
    07-13-2014 08:53 PM
  2. Golfdriver97's Avatar
    I would try installing updated drivers for the phone on your PC. You can find them on Samsung's website. Also, try different cables and USB ports.
    07-14-2014 12:12 AM

Similar Threads

  1. Why can I not find all LG G3 colors?
    By Victoria Ramirez in forum LG G3
    Replies: 5
    Last Post: 07-14-2014, 05:36 PM
  2. My Galaxy S3 home button stopped working
    By Matej Kreze1 in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 07-14-2014, 06:24 AM
  3. Replies: 3
    Last Post: 07-13-2014, 10:27 PM
  4. Uncertainty with G3 enroute
    By jbomb11 in forum LG G3
    Replies: 4
    Last Post: 07-13-2014, 09:44 PM
  5. ATT rooted S3 unable to open settings page after recent firmware update
    By fstone88 in forum AT&T Galaxy S III Rooting, ROM's, and Hack's
    Replies: 0
    Last Post: 07-13-2014, 07:05 PM