1. AC Question's Avatar
    I tried rooting my Samsung Galaxy s4 using odin and it failed and now my phone is stuck. I can only go on download mode. When I press volume down, it would say "firmware upgrade encountered an issue. please select recovery mode in Kies and try again". I tried to use kies, but it would say the device is not updated and I dont think it recognized my device since it keeps saying connecting. When I use download mode on odin, it would say fail and it would get stuck on the downloading screen. I tried all the solutions available but they don't seem to be working for me. Is there anything I can do? I talked to someone from samsung via online tech support and they said to go to a Best Buy and ask for a software reflash. Is there an alternative besides that?
    07-21-2014 08:20 PM
  2. UJ95x's Avatar
    If you have tried recovery mode in Kies then that's probably your only option. If your phone doesn't boot you won't be able to save anything that was on the internal storage or backed up with cloud apps.

    Sent from my Galaxy S4 running SOKP 4.4.2
    07-21-2014 11:11 PM

Similar Threads

  1. Display colour inversion - Galaxy Tab 3 8"
    By Marc2146 in forum Ask a Question
    Replies: 2
    Last Post: 10-04-2015, 09:15 PM
  2. Galaxy S5 Essentials from HOT stock via Amazon - never again
    By jmagid51 in forum Samsung Galaxy S5 Accessories
    Replies: 15
    Last Post: 08-26-2014, 08:10 PM
  3. Galaxy S5 "keyboard shortcuts"
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-08-2014, 01:34 PM
  4. Samsung Galaxy S5 - Copper Gold
    By j_herczog in forum Samsung Galaxy S5
    Replies: 6
    Last Post: 07-22-2014, 06:58 AM
  5. Random text messages gone missing from my s4 mini
    By daveMclean26 in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 07-21-2014, 05:46 PM