1. AC Question's Avatar
    Hi. I'm having a problem with my Samsung Galaxy S4 (SGH-I337M), running on KitKat 4.4.2. About a month ago, the 4G icon at the top of the screen started to blink. It appeared, and disappeared after a second, then reappeared, then disappeared again and so on. Same thing happened when I tried to connect through a non LTE network. Both 3G and H appeared and disappeared after one second.

    At first, I thought it had something to do with the battery being extremely bloated (I figured it was overheating the mobile network antenna), so I got a new battery. After about 4 hours of charging the new battery, I turned my phone on and it was working again.

    Nevertheless, it happened again yesterday, and after one day it still doesn't work. I can connect through wifi, but no mobile network (I can make phone calls, though).

    I've tried everything, short of a restore. I've switched to non-lte network. I've put it on airplane mode and off of it. I've cleaned the cache and got rid of all the junk files. I've reset the network specs to the default ones (Telcel - Mexico), I read somewhere here that I should take the sim card out, it didn't work. My SIM card is exactly a year and two months old.

    Any help would be greatly appreciated. I admit I'm a noob at this, so I definitely need some help here. Thanks!
    07-22-2014 05:47 PM
  2. B. Diddy's Avatar
    Have you actually spoken to the carrier?
    03-03-2015 11:31 PM

Similar Threads

  1. Downloading email problems with Moto G 4G...
    By MrBeee3 in forum Ask a Question
    Replies: 1
    Last Post: 03-03-2015, 11:30 PM
  2. Replies: 1
    Last Post: 11-06-2014, 05:11 AM
  3. Voice to text option not available on Note 3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-24-2014, 08:29 AM
  4. PdaNet + Windows 8 + WiFi Connection problems (Not Rooted)
    By Jeff David Valero in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 07-22-2014, 05:21 PM
  5. Replies: 0
    Last Post: 07-22-2014, 04:48 PM