1. andymcclure's Avatar
    OK, I have an HTC EVO 3D through Virgin. Yes, it's an older phone, but it does everything I need.

    Anyway, I'm having charging problems. It ALWAYS comes up as USB, never AC. I have modified a USB cable to short out the data connections, that didn't work. I have an AC-only wall adapter, that doesn't work. I've tried multiple combinations of different USB cables, wall adapters, etc., and they all come up as USB charge only. I've tried cleaning the USB port, that didn't do anything.

    I've seen a couple apps that will force AC charging, but they all require a root.

    Oh, and once upon a time, it did work just fine, so it's not a problem that has always been there. I'm thinking I could a hard reset, but I'd rather not go through the whole setting everything up again process if I can avoid it.

    Any thoughts?
    07-23-2014 01:48 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is charging much slower when it says USB, even though you're on a wall outlet?
    07-23-2014 04:10 PM
  3. andymcclure's Avatar
    Yes, charging is VERY slow at all times. I frequently run into the "using more power than the charger can supply" issue. In fact, I basically have to leave my phone plugged in all the time so I can have a couple hours worth of charge. At night, I turn the phone off so it can be fully charged by morning.

    Also, I should add that I've tried a new battery (OEM battery, not some 3rd party eBay deal). That didn't do anything, either.
    07-23-2014 04:16 PM
  4. B. Diddy's Avatar
    It sure sounds like a problem with the phone's USB port--not sure a factory reset would do anything. You could see if you could boot into Recovery Mode and wipe the system cache partition. Follow the steps in this video, but instead of selecting the Factory Reset option, try the Recovery option. Then see if there is a Wipe Cache Partition option in the subsequent menu:

    After selecting Recovery, you might have to press some combination of the Volume Down and Power buttons, or the Volume Up and Power buttons, if you see an Android with a red exclamation mark. If you get stuck, just hold the Power button down for about 10 seconds, and the phone should power back down.
    07-23-2014 04:22 PM
  5. andymcclure's Avatar
    Thanks for the suggestions. I didn't have any luck with clearing the cache that way.

    My best guess at this point is that it's a physical problem with the USB port. It seems weird to me, though, that it would result in reading non-USB as USB, since that requires more information to be carried between the phone and adapter. If it were the other way (USB not carrying data and/or trying to act like AC) that would make more sense. All I can figure is that the phone has some sort of default that forces it to USB (and therefore lesser power draw) when there's a problem.

    I suppose I just have to deal with really slow charging until I can get a new phone. (I don't feel confident in my ability to replace the USB port.)
    07-31-2014 09:18 AM

Similar Threads

  1. HTC One M8 default phone app
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-04-2014, 10:34 PM
  2. Can't view pics from SD on HTC ONE M8 in gallery
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-04-2014, 10:24 PM
  3. AT&T G3 qi charging
    By mr.wizard in forum LG G3
    Replies: 4
    Last Post: 07-26-2014, 11:13 AM
  4. 4.4.2 update messed up charging
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 07-24-2014, 01:57 PM
  5. Micro USB 2.0 port
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-23-2014, 12:53 PM