1. AC Question's Avatar
    My phone (Lenovo A680) hangs up while I'm using the facebook app. I cannot turn it off using the power button so I removed the battery. But when I put it back and tried to open it again, it won't turn on or even show the logo screen. What should I do?
    07-24-2014 10:09 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you saying that this occurs frequently, or did it just occur this one time, and it hasn't turned on since? When you say it hung up, do you mean it froze, or did the phone suddenly just shut down?

    If the phone isn't turning on, see what happens if you press and hold the Power button for about 15 seconds. If that doesn't help, you might want to try a new battery.
    07-24-2014 01:38 PM
  3. LL0516's Avatar
    Hi, Op here. Sorry if my question was kinda unclear. When I say it hung up, i meant it froze. It happened only that one time, then it won't open ever since. It's a pretty new phone, so I don't really think it's a problem with the battery. But just in case, is there anyway to test it out except buying a new battery?

    I tried holding on the power button, tried removing the battery then putting it back again, tried holding on the power and volume up button, but nothing happened.

    Thank you in advance.
    07-24-2014 07:25 PM
  4. B. Diddy's Avatar
    Batteries can fail early or be defective. Take it out, lay it flat on a table, and spin it. If it spins freely, it's bulging in the middle, which is a bad sign. Otherwise, since the phone is pretty new, I'd talk to your wireless store or to Samsung about a replacement.
    07-24-2014 08:59 PM

Similar Threads

  1. Replies: 1
    Last Post: 08-17-2014, 02:51 AM
  2. Phone Addiction
    By strickforce in forum General News & Discussion
    Replies: 3
    Last Post: 07-25-2014, 04:06 PM
  3. Stock KitKat phone app.
    By twstrickland in forum LG G3
    Replies: 8
    Last Post: 07-24-2014, 09:53 PM
  4. My phone cant chargeee
    By note 3 Hor Junjie in forum Ask a Question
    Replies: 1
    Last Post: 07-24-2014, 08:44 AM
  5. unable to open
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-24-2014, 08:37 AM