1. AC Question's Avatar
    I have a ZTE Imperial android phone running 4.1.2. So I wanted to get 4.4 on it so I rooted it and it didn't work lol I didn't really know what I was doing I thought you just had to root it.. Anyways I wanted my phone back to the way it was (unroot) so I did a factory reset on my phone in my settings so I let it do it's thing and then I came back in my room to find the screen was blank. So I restarted it and now all it does is show ZTE Logo and then goes to blank screen. I don't think its bricked.. I can boot it into recovery mode but that doesn't help I also tried to reset it into recovery mode but it still doesn't do anything . I tried flashing it with different roms and that didn't work either it says installation aborted. Can anyone please help me and maybe find me a rom so I can flash my phone please anyone help I just want my phone back
    07-26-2014 04:54 PM
  2. Golfdriver97's Avatar
    You can try wiping cache in recovery. That might help. You might also have to reflash your stock ROM, however, I do not know how to with a ZTE.
    07-26-2014 11:51 PM

Similar Threads

  1. Moto E - sound problem, help!
    By ronclone in forum Moto E (2014)
    Replies: 16
    Last Post: 07-16-2018, 07:17 AM
  2. App Available to send, receive SMS/phone calls on PC via Note 3?
    By mattsmusic in forum AT&T Samsung Galaxy Note 3
    Replies: 1
    Last Post: 07-28-2014, 11:54 AM
  3. Samsung S3 screen black
    By Krismbarn in forum Ask a Question
    Replies: 3
    Last Post: 07-26-2014, 06:05 PM
  4. T-Mobile LG G3 and International Capabilities
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-26-2014, 04:41 PM