1. DenizC's Avatar
    I have a relatively new (using it for 3 days only) Prestigio MultiPad 8.0 HD tablet with Android 4.2 and it froze while I was browsing the Dailymotion app that I have just installed. The tablet wasn't responding, so I had no other choice except to shut it down and re-boot it. When I tried to reboot it, it got stuck on the startup screen with the manufacturer's logo. I left it open for over half an hour but no progress.
    I did my research on the net, tried the combination of keys required to enter factory mode (Power + Volume+), but no menu appeared to me, the startup screen was still there.
    I tried connecting it with my computer, and it was detected as an M3 Chip device with no drivers installed. There's no drivers provided on the manufacturer's site, only the latest firmware. After that, I searched the net and the only proper suggestions I encountered were ADB drivers and Moborobo given here. None of them worked because they require USB debugging being enabled, an option I can't access and modify under the current circumstances.

    My questions are:
    1. What tools can I use to install USB Android drivers other than those two I mentioned above?
    2. Is there any way to do a hard/factory reset that can be done through my PC and doesn't require entering the factory mode of my tablet device?
    07-27-2014 07:48 PM
  2. Golfdriver97's Avatar
    07-27-2014 07:53 PM

Similar Threads

  1. Has anyone experienced lag on their note 3 yet?
    By kami8586 in forum Samsung Galaxy Note 3
    Replies: 7
    Last Post: 08-07-2014, 10:55 AM
  2. Replies: 6
    Last Post: 08-01-2014, 05:17 AM
  3. Real life battery on Nexus 5 ?
    By Sergiusz Jasper in forum Ask a Question
    Replies: 7
    Last Post: 07-28-2014, 04:08 PM
  4. Accessing email addresses on HTC Evo 3D
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-27-2014, 08:58 PM
  5. Replies: 1
    Last Post: 07-27-2014, 08:24 PM