1. AC Question's Avatar

    One of my friends recently tried to root his Samsung galaxy Xcover 2 (GT-S7710), but when he was on the download screen with Odin running on the PC, the phone got stuck on the downloading screen so he unplugged the USB (that was a really bad idea to my knowledge). Now the phone will not power on unless connected to a computer or charger, and a screen comes up saying that you must perform an emergency recovery through Kies. The problem is, when the device powers on to that screen, about ten seconds later it powers off again, so Kies does not display the device in the window that is supposed to display a list of devices that require an emergency recovery. I have tried to boot the device into recovery mode (vol-, power and home key held down) but it does not boot the device unless it is connected to a power source, and again powers off after a certain length of time. The device is unlocked and about 4 months old.

    Is there anything that can be done? I have tried charging the device but to no positive result.

    Hope someone can help :P

    07-28-2014 08:56 AM
  2. Golfdriver97's Avatar
    I would suggest looking at a JTAG service. That is probably the only thing that can help now.
    07-28-2014 09:17 AM

Similar Threads

  1. Galaxy S3 Mini Issue - Apps will NOT download or update
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 08-28-2014, 12:08 PM
  2. Root AT&T G3: Basic Questions
    By blackdogAC in forum LG G3
    Replies: 17
    Last Post: 07-29-2014, 11:27 PM
  3. Samsung Galaxy S5 - Notifications won't stop on emails
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-28-2014, 10:45 AM
  4. Replies: 0
    Last Post: 07-28-2014, 08:01 AM
  5. Help connecting Samsung Galaxy via Bluetooth with Jabra Freeway
    By DanHarvard in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 07-28-2014, 06:51 AM