1. AC Question's Avatar
    I replaced the digitizer on my Nexus 4 and followed the directions with great care. Everything is connected and nothing is out of place. However when I go to switch on the phone - a red light flashes at the bottom. I tried holding down volume down + power button and then plugging it into a usb cable (many people swear by this procedure: http://forums.androidcentral.com/goo...-charge-3.html).

    It doesn't work for my nexus sadly. I just wanted to know if there is anyone out there who can also hear noises from their Nexus even though the screen is black. I heard the camera take a photo, I also heard a message come in. Then silence. It seems like the LCD is broken, if the sound is working...but then again, it's a brand new digitizer and this phone is very glitchy so I don't know what to believe.

    I don't have a warranty on this phone anyway as my Aunt gave it to me second hand, as she now has another phone.
    So I'm all ears on any advice,
    07-29-2014 05:52 PM
  2. abdel87's Avatar

    I'm having the same problem, i have a black screen , and i can hear the sound of my Nexus 4 , i took a screenshot by holding power button and volume down button toghether , i heard a voice, seems the phone still working but nothing on the screen, it keeps black, i have followed all the instructions on this topic "[Solved] Nexus 4 won't turn on or charge " , nothing works for me , even on the bootloader menu the screen keeps blacking , i can see something on the screen but there's no brightness at all , i dont know what to do now ,please any advise ??? i hope you found a solution for this.
    09-28-2014 03:05 PM

Similar Threads

  1. Samsung S5 Facebook Photo Issues- White screen, no pics
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-10-2014, 02:47 PM
  2. my phone made a loud shrieking noise and went black
    By dovakar in forum Google Nexus 4
    Replies: 3
    Last Post: 07-29-2014, 04:50 PM
  3. downloading books on a nexus 7
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-29-2014, 03:53 PM
  4. Can't save Farorites on YouTube App!!
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 07-29-2014, 03:43 PM
  5. Softbricked I9300, flashed CF-Auto but still not unbricked :(
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-29-2014, 11:58 AM