1. Davinder Sanghera's Avatar
    Hi guys,

    I have a nexus 7 2013 bootloader is unlocked and it's rooted stick mount install but when I plug it a flash drive with a otg cable it doesn't even recognise that anything is plugged in.

    It recognises pc connection and it charges just fine.

    Really frustrating, what could it be that's stopping it recognising the USB drive?

    Thanks in advance

    07-29-2014 11:27 PM
  2. srkmagnus's Avatar
    According to the troubleshooting section of the App, the Developer recommends trying another otg cable. Have you done that?

    Also, if you can connect another USB device that may help identify the problem if it's related to the stick.

    Sent from my Nexus 5 using AC Forums mobile app
    07-30-2014 12:12 AM
  3. Davinder Sanghera's Avatar
    Yep tried different cables and USB sticks, all work on my other nexus 7 3g no problems.
    07-30-2014 12:16 AM
  4. Davinder Sanghera's Avatar
    07-30-2014 10:51 AM
  5. codebetweenthelines's Avatar
    Why do you think the Nexus doesn't recognize the stick ? what app are you using to reach the data ?
    07-30-2014 10:55 AM
  6. Davinder Sanghera's Avatar
    There is no notification of it being plugged in, used stick out and it says no USB stick connected
    07-30-2014 11:09 AM
  7. codebetweenthelines's Avatar
    I'm not sure it gives notifications.
    I never received for my Nexus devices.

    Try using ES File Explorer to access the USB.
    After trying a few apps this is the one that worked for me.

    You can see a screen cap at: Code Between The Lines: Nexus USB OTG (On The Go)
    07-30-2014 11:21 AM
  8. Davinder Sanghera's Avatar
    On my other n7 a notification pops up saying USB mass storage in the bar along the top, on this on nothing, tried ms file explorer, a long with many others, no joy.

    As the port works for PC and charging, and the otg cable and USB drive work, I can only guess that its a software/settings issues.

    As to what I'm stuck, come on android gods, help me please.
    07-30-2014 02:38 PM
  9. codebetweenthelines's Avatar
    Really ? you got a notification ?
    I didn't get one on my nexus 5 or nexus 7.
    What version are you running?
    I checked with 4.4.3 and 4.4.4, no notification but ES File explorer could see the drive like in the screen before.

    as for settings,
    the only "special" settings I have open are :
    1 - allow unknown sources
    2 - USB, connect as Media device (MTP)
    07-30-2014 04:10 PM

Similar Threads

  1. How can I unroot my nexus 7 (2013) that is rooted but locked?
    By MAChang in forum Google Nexus 7 (2013) Rooting, ROMs, & Hacks
    Replies: 5
    Last Post: 11-18-2015, 04:50 PM
  2. Galaxy S4 will not turn on or charge, no issue with battery.
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 09-19-2014, 07:51 PM
  3. No recent apps
    By DudeThatsErin in forum LG G3
    Replies: 4
    Last Post: 08-05-2014, 04:33 PM
  4. No signal after update
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 07-30-2014, 11:23 AM
  5. "No Connection" BUT ITS ____ING CONNECTED!!!!!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-29-2014, 09:45 PM