1. FreddieF's Avatar
    Since yesterday my S5 would not install any app I downloaded. I tried to install a new app from the Play Store: it would download, but then nothing happens...
    I tried updating a app via Play Store: same thing.
    I downloaded the Amazon App Shop-App, the APK is saved on my device, but when I tap on it to install it, nothing happens...

    What kind of sorcery is this?
    07-31-2014 09:06 AM
  2. B. Diddy's Avatar
    Make sure the Download Manager isn't disabled somehow. Go to the App Manager, select Download Manager, and select Enable if it's disabled.

    Since it isn't installing the Amazon Appstore apk, I assume this isn't an isolated Google Play Store issue. You might want to try booting into Recovery and wiping the system cache partition: Reset: Samsung Galaxy S 5 | T-Mobile Support
    07-31-2014 12:53 PM
  3. FreddieF's Avatar
    Thank you so much!!!

    The wipe helped.
    07-31-2014 01:06 PM
  4. B. Diddy's Avatar
    No, wiping the cache partition won't erase any personal data.
    07-31-2014 01:15 PM
  5. FreddieF's Avatar
    Wiping the Cache solved the problem!
    10-06-2014 08:10 AM

Similar Threads

  1. Replies: 1
    Last Post: 09-28-2014, 05:51 PM
  2. Email app auto correct...how to stop? ??
    By Nychotxxx in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 5
    Last Post: 08-03-2014, 01:23 PM
  3. App icon badge number
    By fleeper in forum General News & Discussion
    Replies: 3
    Last Post: 07-31-2014, 01:36 PM
  4. Youtube app on GS5 stops video but audio is fine
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 07-31-2014, 01:10 PM
  5. Amazon Appstore :$100 worth of paid apps free
    By dpham00 in forum Android Apps
    Replies: 1
    Last Post: 07-31-2014, 07:37 AM