1. morgan leew's Avatar
    Hi there I have just brought a new Alcatel one touch 6010x , I cannot use play store or browser yet my emails still come through, i am trying to use wifi, it says I am connected but i still have these problems, I went to the Vodafone store today and it worked perfectly on their wifi! And they thought it would be fixed once they put on on the network properly but I get home and it's the same problem? Play store will try to download an app but get stuck and after 5 min of trying it will say could not download due to error 495, help would be much appreciated!
    Thanks
    08-01-2014 12:27 AM
  2. morgan leew's Avatar
    Okay it was just working on browser my bad but no play store downloads work?....
    08-01-2014 12:49 AM
  3. belodion's Avatar
    Are you trying to download on mobile data, or wifi? Have you tried both?

    Posted via Android Central App
    08-01-2014 05:43 PM

Similar Threads

  1. The One...Watch?
    By rob damiani in forum Android Wear
    Replies: 2
    Last Post: 08-04-2014, 10:00 AM
  2. Game compatibility issues...
    By Beka27 in forum LG G3
    Replies: 13
    Last Post: 08-01-2014, 05:56 PM
  3. Sprint HTC One is Totally locked
    By Dale Jackman in forum Sprint HTC One
    Replies: 1
    Last Post: 08-01-2014, 08:29 AM
  4. Touch screen on Samsung S3 not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-01-2014, 12:01 AM
  5. Kit Kat Issue
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-31-2014, 06:15 PM
LINK TO POST COPIED TO CLIPBOARD