1. Asiya Zafar's Avatar
    HI, my s3 gt-i9300 is stuck on samsung logo . i have this problem a few months ago but i have solved it with kies but know kies says that my device will not up date plz help me
    08-02-2014 03:30 PM
  2. STARGATE's Avatar
    Did you try a factory reset or it was off and you turned it on?

    Sent From Another Galaxy
    08-02-2014 04:19 PM
  3. Asiya Zafar's Avatar
    YES i have try factory reset ,reboot and download frimware from odin kitkat 4.2 but nothing happen its still stuck and i was making video when it stuck and then i thought that my battery is finished i tried to on it but then isaw that grey battery loop
    08-03-2014 02:57 AM
  4. Asiya Zafar's Avatar
    plz send me alink that allows to completely download frim ware for s3 gt-i9300 for region united arab emrites
    08-05-2014 03:25 AM

Similar Threads

  1. kyocera brigadier - any hands on reviews or comments?
    By AC Question in forum Ask a Question
    Replies: 23
    Last Post: 08-14-2016, 04:01 PM
  2. controlling google play on my 7 using my I phone?
    By macman4 in forum Google Nexus 7 Tablet (2013)
    Replies: 2
    Last Post: 08-03-2014, 04:23 AM
  3. Sluggish wi-fi speed on Tab S 8.4
    By hsbridge in forum Samsung Galaxy Tab S 8.4
    Replies: 1
    Last Post: 08-02-2014, 04:28 PM
  4. Mic problems on LG G2
    By Harold Briedenbaugh in forum Ask a Question
    Replies: 0
    Last Post: 08-02-2014, 03:04 PM
  5. Replies: 0
    Last Post: 08-02-2014, 02:23 PM