1. Patelvishal4364's Avatar
    I have a Samsung Galaxy S4. Today morning i was Playing "Real Cricket `14" and my phone rebooted!! Ok i thought it happens...But i was waiting for it to get start again..and itjst showed up the device name as"Sam..Galx..S4 GTI9500" and again black...again the name...again the black...now i took out the battery...and again inserted it...and it doesnt allows me to make a start...it jst starts the same process again...still i waiting for the battery to go dead...Plze any one help me out...
    08-03-2014 01:46 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! It's possible the battery could be failing. Take it out, place it flat on a table, and try to spin it. If it spins freely, it's bulging in the middle, which is a bad sign--try a new battery. But even if it doesn't spin, it's worth trying a new battery any way.

    You can also try booting into Recovery Mode and wiping the cache partition: Reset: Samsung Galaxy S 5 | T-Mobile Support

    If you have an SD card inserted, try booting with the card removed, since a corrupt card could cause issues.
    08-03-2014 01:55 AM
  3. Patelvishal4364's Avatar
    i tried the spins i think battery is alright! and i even tried to reboot without the SD card! Still the same thing! And i m not able to go for a recovery mode coz the name appers for a second or two...and the mode thing doesnt apper in this much time..
    08-03-2014 03:28 AM

Similar Threads

  1. help atrix 4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-30-2015, 01:34 AM
  2. [HELP] My s4 won't turn on
    By eprpalmeida in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 08-03-2014, 10:30 PM
  3. please help me!
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 08-03-2014, 08:20 PM
  4. Software Update Removed Keyboard Sound - Please Help!
    By JakePleasants in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 08-02-2014, 10:53 PM
  5. Replies: 2
    Last Post: 08-02-2014, 05:42 PM