1. AC Question's Avatar
    Hi all,

    I bought a Galaxy S3 some time ago in California, but my main use of the phone is abroad. When I insert a SIM card (tried with two different mobile networks, so it's not one specific network), I do have calls and text messages. However - I am not able to connect to the internet (via the mobile network). When I try accessing the settings, and tap on "Mobile networks", I get a message saying "Insert SIM card to access network services". So on the one hand it doesn't recognize the SIM card, and that's why I cannot connect to the internet, but on the other I do have calls and text messages.

    I tried with different cellular networks, and I also tried factory resetting the dvevice and formatting etc.

    I read a lot about this problem online, but I couldn't find any solution to the problem. So should I simply give up on my phone and get another one? Is there anything I could do?

    P.S. going back to the store/lab etc. isn't possible for me because I don't plan on visiting California any time soon...

    Thanks!
    08-05-2014 01:48 PM
  2. Indoler's Avatar
    Hi all,

    I bought a Galaxy S3 some time ago in California, but my main use of the phone is abroad. When I insert a SIM card (tried with two different mobile networks, so it's not one specific network), I do have calls and text messages. However - I am not able to connect to the internet (via the mobile network). When I try accessing the settings, and tap on "Mobile networks", I get a message saying "Insert SIM card to access network services". So on the one hand it doesn't recognize the SIM card, and that's why I cannot connect to the internet, but on the other I do have calls and text messages.

    I tried with different cellular networks, and I also tried factory resetting the dvevice and formatting etc.

    I read a lot about this problem online, but I couldn't find any solution to the problem. So should I simply give up on my phone and get another one? Is there anything I could do?

    P.S. going back to the store/lab etc. isn't possible for me because I don't plan on visiting California any time soon...
    For using mobile data when you are 'abroad' you need 'roaming' enabled in the Settings. Is it?
    BTW mobile data are expensive. When 'abroad' – so when you're 'roaming' – it's super expensive!
    anon8380037 likes this.
    08-05-2014 02:25 PM
  3. anon8380037's Avatar
    ..... and have you had the apn settings installed for each sim. You may have to switch between them.
    Connections - More Networks - Mobile Networks - Access Point Names.

    Sent from my SM-N9005 using Tapatalk Pro
    08-05-2014 03:01 PM
  4. Almeuit's Avatar
    ..... and have you had the apn settings installed for each sim. You may have to switch between them.
    Connections - More Networks - Mobile Networks - Access Point Names.

    Sent from my SM-N9005 using Tapatalk Pro
    This.

    Sent from my T-Mobile Note 3 using AC Forums.
    anon8380037 likes this.
    08-05-2014 03:08 PM
  5. MrCrumbs's Avatar
    Hey,

    About the APN - as I said, once I tap on "Mobile Networks" it shows a message "Insert SIM card to access network services", and it doesn't let me in the settings, so I cannot change anything there manually.
    I did send a text message to the carrier as they instructed in one of their pages. It was supposed to send me back automatically a settings file that I only have to confirm, but it never sent me anything like that.. so I can't really change any of those settings because tapping "Mobile Networks" just pulls the message I wrote earlier..
    08-05-2014 03:30 PM
  6. Almeuit's Avatar
    I would go to your carrier and get a new SIM card.

    Sent from my T-Mobile Note 3 using AC Forums.
    08-05-2014 03:42 PM
  7. MrCrumbs's Avatar
    Hey, thanks, but I already tried two SIM cards from my carrier, and even one from a different carrier. They all had the same problem
    08-05-2014 03:43 PM
  8. Almeuit's Avatar
    The only thing I can think of then is to factory reset.. If that doesn't work then I'm not sure what could be the issue since phone calls and text messages work.. Just not the data.

    It also makes sense you didn't receive the file from your carrier. It would come as an MMS message and that needs mobile data to download.

    Sent from my T-Mobile Note 3 using AC Forums.
    08-05-2014 03:46 PM
  9. Golfdriver97's Avatar
    Since it isn't sim related, the only thing I can think of is a hardware issue

    Signed, an M8, Liquidsmooth, and the AC Forums App
    08-05-2014 03:48 PM
  10. MrCrumbs's Avatar
    I see, well you can't win them all. Thanks.
    08-05-2014 03:50 PM
  11. belodion's Avatar
    Hey,

    About the APN - as I said, once I tap on "Mobile Networks" it shows a message "Insert SIM card to access network services", and it doesn't let me in the settings, so I cannot change anything there manually.
    I did send a text message to the carrier as they instructed in one of their pages. It was supposed to send me back automatically a settings file that I only have to confirm, but it never sent me anything like that.. so I can't really change any of those settings because tapping "Mobile Networks" just pulls the message I wrote earlier..
    Have you tried tapping Mobile Networks with the SIM out, then when you get the message, inserting it and seeing whether it recognises it and lets you enter the APN settings?

    Posted via Android Central App
    08-05-2014 03:50 PM
  12. MrCrumbs's Avatar
    Nope I haven't tried that out. Thanks for the suggestion, I will try it out later when I get home and see if this works.
    08-05-2014 03:53 PM
  13. anon8380037's Avatar
    Maybe it's not region compatible?
    Golfdriver97 likes this.
    08-05-2014 03:56 PM
  14. MrCrumbs's Avatar
    Yes someone else told me to check out the model as well to see if the bands and frequency are supposed to work. I will check that out too when I get home.
    08-05-2014 03:58 PM
  15. MrCrumbs's Avatar
    Sorry for the delay, I lost my phone and just now found it again. I tried inserting the SIM only when requested, and still it doesn't work. The model no. is I9300, which should work... so I still can't find a solution. Thanks anyway!
    08-11-2014 08:14 AM
  16. belodion's Avatar
    A user in another thread said he could only connect to wifi by switching on Airplane Mode first. As a last desperate attempt, with a few minutes to fill, you could try to set up while toggling that in various combinations...you never know. (Although you can be pretty dang sure it won't work.)

    Posted via Android Central App
    08-11-2014 09:00 AM

Similar Threads

  1. Replies: 13
    Last Post: 06-15-2015, 11:44 PM
  2. Connecting my home to Google Now (and other voice commands)
    By whitenack in forum General Help and How To
    Replies: 6
    Last Post: 02-03-2015, 07:57 AM
  3. Dropbox drains battery on Galaxy S5
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 08-05-2014, 07:58 PM
  4. Replies: 0
    Last Post: 08-05-2014, 01:24 PM
  5. Droid Maxx: Completely Dead (Water) - Data recovery possible?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-05-2014, 01:12 PM
LINK TO POST COPIED TO CLIPBOARD