1. AC Question's Avatar
    I just recently purchased a Galaxy S3 mini (I8200L) from Amazon. It came in yesterday and worked like a charm. However, I had the bright idea of trying to root it so I can flash a custom mod on it. I used odin to try to root it, but I used a .tar file for a DIFFERENT S3 mini model, not the I8200L that I have. So now I think my phone is bricked. When I turn it on, the screen says "Firmware upgrade encountered an issue. Please select recovery mode in Kies and try again". I tried using Kies but my phone does not show up, it just has a perpetual "connecting" icon but it never does connect. I've tried troubleshooting it and all that good stuff to no avail. I actually just opened (or tried to) as I am writing this and it said "Fatal Error". So Kies is out of the question, and I can't put my phone into recovery mode. Is there anything I can do to fix my phone? Or am I going to have to contact the fine folks at the Samsung Kiosk at my local Best Buy? Thank you in advance!
    08-06-2014 06:23 PM

Similar Threads

  1. Very low-def Screenshots after latest update - Galaxy S4
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-14-2014, 02:23 AM
  2. Galaxy S4 GPe no longer on Play Store?
    By Ry in forum Samsung Galaxy S4 Google Edition
    Replies: 1
    Last Post: 08-11-2014, 09:13 AM
  3. Replies: 3
    Last Post: 08-07-2014, 04:05 PM
  4. Replies: 4
    Last Post: 08-07-2014, 08:10 AM
  5. Replies: 1
    Last Post: 08-06-2014, 07:48 PM