1. AC Question's Avatar
    Problems with Kit Kat upgrade on Samsung Galaxy S4. Failing to get a data signal when phone is Switched on (booted up).

    I have decided to write this and paste it onto any web site or pages I can find belonging to EE in the UK, Samsung and Google Android.

    Why you might ask, because of the appalling behaviour of these companies and the total lack of help and assistance I received, so that others can learn form my experience and hopefully, this will help them.

    I bought this Galaxy S4, which is by the way, a brilliant phone and overall I am happy with it, in Feb 2014. I had owned it for approximately 6 weeks when the first of two Kit Kat upgrades arrived. In that first 6 weeks I had absolutely no problems and everything worked perfectly.

    I should point out that I am a secure type of person, so my phone has a SIM lock set up and a Phone lock, both requiring pin's to be entered. These both worked perfectly for the whole of the first 6 weeks and in fact I had an SII before that and had operated the same way for 2 years. Also, this phone is 4G and in central London phone and data signals were great and even out in Bucks, where I live, I would get a 4G data signal and 4 bar strength for the phone signal before the Kit Kat upgrade.

    After taking the first of the upgrades I started to get situations where I could not get a data signal when booting up my phone in the mornings at home. The keyboard would lock at times, not allowing the pins to be entered and also the phone signal strength was regularly 2 or 1 bar, where it had previously been 4. But the biggest problem by far was the lack of a data signal. After booting up and entering the pins. I would notice that I had no data signal and would pull down the top status bar and go to the green buttons (don't know what they are called) and select the “Mobile data” button which was greyed out and when pressed I would get an error “Insert SIM card to access network services”.

    Of course the phone and sim were all in perfect working order and this error was rubbish. With in a couple of days the lack of a data signal at home in the mornings was happening every morning and I even had situations where I failed to get a data signal for whole 24 hour periods. Especially at home on weekends.

    I found that when I got to the station in the morning, the signal strength was better and sometimes I would get a data signal, some times not. When I got to work in central London 90% of the time I got a data signal and all worked OK. This always required the phone to be rebooted.

    During this period I had contacted both Samsung and EE and reported the issue. I also got a 2nd Kit Kat upgrade approximate 2 weeks after the original and it made no difference.

    Samsung took the stance that there was nothing wrong with their software and it was an EE network issue and washed their hands of it. Very unprofessional in my view. You would have expected them to show interest in an issue to firmly establish that it was not an issue with their software and that it was definitely an EE problem.

    I should add that other than my last contact with EE, all of the companies in all contacts with them expressed never having encountered or heard of this issue before. Later to be an embarrassment to EE.

    EE had also initially played the same game and tried to blame Samsung, but in the end took on the issues and then put me through a series of hoops to try and resolve the issue all of which failed and just left me more and more frustrated as the weeks rolled on.

    Initially I had to keep a log of all events to prove that there was a consistent problem, my word and experiences were not good enough. So I did that for nearly 2 weeks.

    They sent a “Refresh” to my phone, did exactly as was instructed, made no difference at all. This refresh caused my hone to switch to the time zone for Armenia, so god knows what they were doing.

    By the way, every time the phone failed to get a data signal, I would make multiple attempts to reboot, take the battery out, sim out and anything else that had been suggested, all to no avail.

    I was then told to take it to the EE shop in my town and they would have a look at it and would be expecting me. Rubbish, no contact between EE and the shop, because the shop is a franchise. They knew nothing about it, but took the phone and performed diagnostics on it and found nothing wrong with it. I was told that the phone was outstanding a Samsung update and that I would find it on their web site. Not that helpful really, Samsung web site is poor at best, unless of course you are buying. Couldn't find any update for my phone mentioned on the Samsung web site and checking in the “About” Settings options on the phone, said it was up to date, so no outstanding updates. More rubbish to fob me off.

    I was then told by EE that I would have to take the phone to the Samsung authorised repair centre in my town. Took the phone in and they completely wiped it and gave me it back in a pew phone state or factory reset. Took phone home and rebuilt to my way of using, connected to wifi. As soon as I switched wifi off and tried to get a data signal, got the “insert sim card...” message.

    So all of this messing around had been a complete waste of time and produced absolutely no change.

    EE now wanted to replace the sim, so that was arranged and done and problem persisted.

    One EE person said if that failed, phone would be replaced, next person said it would never be replaced and didn't know why I had been told that. More crap from their support.

    At this point I decided to do some of my own investigations on the internet and found loads of incidences like mine, but not exactly the same, different companies and phones involved and mostly in the USA. But I did find one guys forum entry for the same problem, same phone and same kit kat upgrade and EE. He had been told by his EE contact, that it was a SIM lock issue and that if he turned the SIM Lock OFF all would be OK and apparently it was. I tried this and now, some 3 months later it is still working.

    But I have never had the nerve to turn the sim lock back on, as I don't want that hassle.

    So, all along EE knew they had an issue with SIM LOCK causing loss of data connection, post the Kit Kat upgrade, but at no time did anyone ever tell me that or even acknowledge that it was a known problem. I rang EE again and confronted a guy who did not respond that pleasantly. He said he knew of the problem but had never been told that turning SIM LOCK off was a solution. That was it, they weren't interested anymore, not that they had ever been interested, I had a solution even thou it means my phone is now less secure.

    So clearly the introduction of the Kit Kat upgrade has produced a bug that causes a loss of data connection. It remains unclear to me, because of the lack of assistance of these companies, who's software is actually at fault. They are all so busy making money they really couldn't care about customer service or their customers. The problem persists, as there have been no further upgrades on my phone, so I continue to have to use a phone without SIM LOCK. Personally, I will hold them responsible if my phone ever gets stolen and I incur any sort of costs.

    For those not aware, there are multiple layers of software on these phones. Google Android to begin with, Samsung layer on top and then EE add their layer on top of that. Hence the problem in identifying software at fault and the subsequent blame game played by some companies.

    My current Android version is 4.4.2 and the phone continues to tell me it is up to date and no updates are available. The phone model number is GT-I9505. Kernel version is 3.4.0-481100, dpi@SWDD5908#1, Sat Mar 8 00:28:12 KST 2014. Build number is KOT 49H.I9505XXUFNC4.

    As a business software developer with nearly 40 years experience, my view of this, given what I have seen is that the Kit Kat upgrade produced a clash between software starting up in the boot procedure, one which is handling unlocking the SIM and the other which is trying to obtain a data connection. Clearly the presence of the sim unlocking software is exhibiting systems that causes issues in the data connection software. The problem has clear characteristic and very consistent symptoms that as a software developer, I would have expected these companies developers to be able to reproduced this bug and provide a fix.

    So far, they have shown absolutely no interest in the bug at all.

    Crap testing and customer service from all concerned.

    I hope this spurs them into action and it helps others who are currently banging their heads against a brick wall.
    belodion likes this.
    08-10-2014 10:40 AM
  2. anon8380037's Avatar
    You can wipe a phone, locate or Lock down remotely with Android Device Manager or other. You can stop a sim with your provider. I used sim lock 10 years ago. It would have been worth leaving it unlocked to see. I agree they should have changed the phone if they agreed there was an issue.
    That's my 15 minutes up!
    08-10-2014 11:01 AM

Similar Threads

  1. Replies: 3
    Last Post: 08-11-2014, 10:06 PM
  2. Sync Outlook 2007 Contacts and Calendar with my S3
    By neil154 in forum Ask a Question
    Replies: 0
    Last Post: 08-10-2014, 10:23 AM
  3. Samsung galaxy s3 always safemood
    By Krishan D in forum Ask a Question
    Replies: 0
    Last Post: 08-10-2014, 10:19 AM
  4. S4 crashed trip advisor sreen message won't go away
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-10-2014, 10:16 AM