1. AC Question's Avatar
    Today my phone turned off on its on which has happened before. When I turned it back on the Android system recovery <3e> popped up (green man laying down with and exclamation inside a red triangle coming out its chest). This has happened before and in those cases I always chose the reboot system now which has always worked. Today I chose that option and it turned off and the system recovery screen came back up. So I tried it and the other options also. It either would get stuck on a selection or turn off and go back to the same screen. Help I don't know what to, would be very much appreciated, I cannot afford a new phone right now. Should I call straight talk and have them start a ticket?
    08-12-2014 08:24 PM
  2. B. Diddy's Avatar
    Try removing your SD card, if you have one inserted (in case it's corrupt, which can cause problems).

    Otherwise, try selecting Wipe Cache Partition from that Recovery menu.
    09-08-2014 07:49 PM
  3. Annez Eyu's Avatar
    My samsung galaxy gt-s5360 is stuck
    03-28-2015 11:07 PM

Similar Threads

  1. ASUS Fonepad 7 (FE170CG) hang on asus logo
    By 12-14 in forum ASUS Fonepad 7
    Replies: 1
    Last Post: 10-30-2015, 04:39 AM
  2. Replies: 2
    Last Post: 08-12-2014, 08:18 PM
  3. camera faied error after root on sprint galaxy s3
    By Christopher Digiacomo in forum Ask a Question
    Replies: 0
    Last Post: 08-12-2014, 07:42 PM
  4. Samsung screen does not lock.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2014, 07:36 PM
  5. Computer recognizes my phone as a camera not a Phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2014, 07:35 PM