1. theonlymisse's Avatar
    I am having trouble getting my phone to charge. It was working fine earlier this evening, but after I went for a walk and came home, where I plugged the phone in, and it was showing the battery icon at about 25%, but the little lightning bolt that shows up in the icon when it is charging was not there. I unplugged and plugged it in again, and then the warning came up that my battery is critically low. I did have my phone in my pocket during the walk and when I opened up the back to check the battery, I did notice a lot of moisture along the inside of the back cover, so I took it apart, dried it off, and put it back together again, and I am still not getting a charge to the phone. I have tried switching USB cords, switching the charger, and tried charging through my computer and my computer is not registering the USB device at all. Is it the moisture or is there another, more nefarious issue at play? (The USB cords work when trying to charge other things). I have a Samsung Galaxy Ace 2, if that helps at all.

    Thanks so much!
    08-12-2014 09:47 PM
  2. Golfdriver97's Avatar
    First thing, and easiest thing to check is the battery. Is it swollen? To check, you can take it out and set it on a flat, smooth surface. Try to spin it. If it does, the battery is bad, and may be part, if not all of your problem.
    08-12-2014 10:13 PM

Similar Threads

  1. Replies: 5
    Last Post: 08-13-2014, 01:15 PM
  2. Question about the HTC One M8 home button.
    By Darius Spencer1 in forum HTC One M8
    Replies: 2
    Last Post: 08-12-2014, 11:14 PM
  3. solving this error stuff will trying to install an app
    By beautifulbeulah in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2014, 07:00 PM
  4. Llama Event Trigger Question
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-12-2014, 04:30 PM
  5. Replies: 1
    Last Post: 08-12-2014, 12:28 PM