1. AC Question's Avatar
    Hey guys. I'm using a rooted ATT GS5.

    Recently my Google Keyboard has stopped auto correcting words and showing predictions in multiple browsers, I have tried (Chrome, Chrome Beta, Firefox etc). It had been working fine after root but I switched to Swiftkey to try something different. The keyboard does work correctly in hangouts and my messaging apps. I have tried reinstalling and clearing the caches for each browser and Google Keyboard. Does anybody have any suggestions to fix this?
    08-13-2014 09:50 PM
  2. UJ95x's Avatar
    When you go into keyboard settings for Google Keyboard, is auto correction turned on?

    Sent from my Galaxy S4 running SlimKat 4.4.4
    08-14-2014 03:29 AM
  3. Egosascyth's Avatar
    When you go into keyboard settings for Google Keyboard, is auto correction turned on?

    Sent from my Galaxy S4 running SlimKat 4.4.4
    Yes I have the show correction suggestions set to : Always show
    Auto correction is modest. The suggestions/corrections show up in my other apps, just not in my browsers.
    08-15-2014 11:32 PM
  4. Tripledrop's Avatar
    Did you manage to fix this? I'm having the same issues, and it's stopping me using a good keyboard as I use chrome a lot!
    10-02-2014 02:48 PM
  5. mcdonsco's Avatar
    Same problem here on my g2 and considering the scren on this thing has become wonky at best in accurately interpreting key strokes, its a real problem for me...its also how i found this thread.

    Using google keyboard. No autocorrect at all and ive checked and rechecked settings to make sure its on.
    10-08-2014 07:22 PM
  6. mmcdaniel7's Avatar
    I have the same problem on an unrooted Galaxy Note 3, with the Samsung calendar. Samsung's keyboard and SwiftKey work fine but the Google keyboard does not auto correct or predict text in that application. It used to but it seems to have stopped with a most recent update perhaps?
    02-09-2015 10:39 AM
  7. Silverpierce's Avatar
    Same problem as well, since forever.
    03-29-2015 11:58 PM
  8. Jonathan Brown5's Avatar
    Has anybody found a solution to this?

    It seems to be a pervasive problem, but I can't find a solution. I've even factory reset my phone, and still nothing.
    05-06-2015 12:41 PM
  9. Radha Krishna Singh's Avatar
    Go to keyboard and input. Click on the settings for the input type you're using. Go to input, check prediction and auto spell correction.

    Hope this helps. Posted as soon as I fixed it for my moto x.
    05-12-2015 12:48 PM
  10. yasirali66's Avatar
    Try to download the language again from the keyboard settings
    garne2t likes this.
    09-23-2015 06:07 AM
  11. Lisa Heckel's Avatar
    LG g2 I have noticed the same thing. The bar is above some times like now but I'm General when searching google through chrome or Facebook it's non existent. I guess no one has found a solution yet?
    12-01-2015 03:03 AM
  12. Abgunn25's Avatar
    Please let me know if you get a fix its Annoying the hell out of me. It works for example filling in boxes like these but not in browser bar. Thanks
    12-22-2015 12:24 AM
  13. Lisa Heckel's Avatar
    I ended up downloading SWIFTKEY KEYBOARD and it works a treat. Abgunn25 I defo recommend it. Also it's a smart keyboard & has cool colours to pick from. Let me know how you get on.
    If anyone else has an issue like this and also the fact that the space key isn't working on the LG G4 then this is your fix. Trust me. It was making me regret my purchase until I downloaded this keyboard. Hope it helps ya'll. 😀
    12-22-2015 02:36 AM
  14. Mr-E9's Avatar
    After ensuring the autocorrect and next-word suggestion boxed were checked, I was still having problems. Downloading language packs fixed it for me.

    English (US) language pack wouldn't download on my phone for some reason, but there was another just called English and one called English (UK). After downloading these, the problem was fixed.
    12-27-2015 12:07 AM
  15. Terence Cattrell's Avatar
    The only browser I've found it to work in is Dolphin. But this is a really poor design flaw.
    03-12-2016 09:47 AM
  16. saqib ahmed2's Avatar
    Go to languages and input select google keybord in that you will find text corrections click on it then u will see text correction on toggle it to on
    06-17-2016 06:35 PM
  17. snake2332's Avatar
    That's not the problem. The problem is that the Google keyboard doesn't give predictions in all fields, including the address bar of Chrome or the built-in browser on your device. There are other fields that it fails to give predictions, too, which also means it's not spell-checking either. It's a huge design flaw that makes Google keyboard not even an option for most people.

    Personally, I liked Swype keyboard the best because it has good options like long-press delay. However, I stopped using Swype keyboard recently because it accidentally detects a swipe when you hit 2 keys at the same time, and you can't turn off the swipe ability, sadly. Funny that I want to use it for everything OTHER than the swipe ability.

    Smart Keyboard is pretty good, tons of options, but I keep hitting the A key when I try to hit SHIFT, and it felt a little less responsive than Samsung keyboard. Otherwise, this would be my favorite keyboard. I could probably adjust the keyboard to be really tall and I'd stop missing the shift key, but then it would take up too much room.

    I haven't tried Swiftkey in forever because it was also failing to give predictions and spell-check in many fields, just like Google keyboard. I just installed it and it looks like it is giving predictions in every field now. Sweet, I might start using it as my main keyboard.

    Kii used to be my go-to keyboard but they didn't seem to update for uhhh Android 5.1 or some time around then, so it's not an option anymore. Too bad really, they had the perfect keyboard in my opinion.

    Latley, it's Samsung keyboard for me. No long-press delay setting, but luckily it's short enough (feels like 350ms maybe, and I'd like 230ms...oh well). It's responsive, gives predictions everywhere, and let's you change swiping gesture to "move cursor" instead of Swype-style typing. I wish you could make the secondary-key symbols a bit larger. They are freaking tiny even on my Note 5 and S7 Edge, and especially tiny on my work phone S6 (is that semi colon or normal colon?) My buddy complains about how it suggests email addresses from his contacts, and even though he somehow tells it not to, they come back the next day. He's super-picky though, even more so than I. I might try Swiftkey again since it looks like they improved it since last time I used it (3 years ago or something).
    BladeJrs likes this.
    08-16-2016 11:47 AM
  18. silmarnoe's Avatar
    This is a bit late, but of you are having the issue while typing into the search bar (address bar), check to ensure you have enabled whatever browser you use to "use web service to fix spelling errors and give predictions" (should be something like that on them all). I know this works for chrome, but it's a personal privacy preference... ease of use vs a semblance of privacy.. Now if it happens on certain sites, like this one for instance, that is controlled by the site. Similar to how sites don't predict anything in password or username spots (autofill is different), the site or "word" program they employ may be too rudimentary to allow it.
    09-08-2016 07:22 PM
  19. twinkmot's Avatar
    After hours and hours of pointless googling, here what resolved the issue for me. Xposed framework and this module Always Correct | Xposed Module Repository.
    Tolga Erol likes this.
    10-16-2016 10:43 AM
  20. akajr95's Avatar
    What I did was go to application and go to running and the to Samsung keyboard and cleared catch and data should fix the issue.
    12-13-2016 04:31 AM
  21. Lpbmarks's Avatar
    I almost figured it out. Since I can't seem to delete this post I will share what I found, it does help at least in some apps. Kind of gets you closer to the end goal.

    Inside Gboard settings:
    1) Go to "Languages"
    2) Uncheck "Use system language"
    3) Check "English"

    As well as make sure all the other settings are set for auto-correction, etc.
    the tall guy likes this.
    01-16-2017 09:39 PM
  22. easyrotor's Avatar
    I tried all the solutions except downloading twikmot's apk. The one that fixed it for me was adding the United Kingdom Language to my Pixel XL in Settings/Language & Input/Languages.
    04-01-2017 02:29 PM
  23. DEDEVaughn's Avatar
    I've not been able to figure out how to do this...I can't remember where I went, it's been a few days, but UK wasn't an option in my list.
    04-18-2017 10:56 PM
  24. Eddie R's Avatar
    I hate this new update for the same reason. Words don't get separated the way they used to and auto predict sucks now. I looked up how to change this in settings. I went to about update and it says if you want to keep your previous keyboard then select that option when you first open it in the new update. Problem is i already am past that point now. I do not want to have to reset phone to get old texting back. I have opened up the Samsung messaging app and it works much better than the Verizon messages but still not as smooth as it used to be. Help!
    04-25-2017 04:06 PM
  25. Jeffrey Gan's Avatar
    Had the same problem after an update. Fixed by going to Gboard, language, select English instead of the default Use system language.
    05-01-2017 01:27 AM

Similar Threads

  1. built-in dialer app
    By Eslam Elbyaly in forum Ask a Question
    Replies: 21
    Last Post: 09-21-2016, 01:54 PM
  2. Replies: 6
    Last Post: 09-17-2014, 11:08 AM
  3. Why Google Mobile Search saves everything I've typed
    By Super Meat Boy in forum Ask a Question
    Replies: 2
    Last Post: 09-05-2014, 03:12 AM
  4. Not able to Send or Receive Any Texts- HTC One M8
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-13-2014, 08:28 PM
  5. Help! My Gmail address doesn't appear in my stock email app.
    By datawalla in forum AT&T Samsung Galaxy Note 3
    Replies: 0
    Last Post: 08-13-2014, 05:36 PM
LINK TO POST COPIED TO CLIPBOARD