1. AC Question's Avatar
    I have taken the battery out & even plugged it to my hard drive of my desktop computer & nothing. My computer didn't even recognize something was plugged into it. Please HELP!
    08-16-2014 09:34 AM
  2. Paul627g's Avatar
    What happened leading up to this? Was the phone functioning properly when you plugged it in last to charge? Was it turned on or off? Has there been any physical damage like dropped, thrown, water exposure recently?
    08-16-2014 09:41 AM
  3. VidJunky's Avatar
    First I'm assuming that you meant that you did a battery pull and had no result, and then attempted with the phone plugged in and got no result. Since you didn't mention any damage or other mishap that the device simply stopped powering on after a charge. Did you allow the phone to die, I mean did you let the battery deplete to 0 and it powered its self off? This can be kind of bad for smartphones and there are articles out there about not allowing this to happen. When you pulled the battery how long did you keep it out? There are small capacitors in these devices and you should allow at least a full minute for them to discharge before replacing the battery. How do you know the battery is fully charged? Is the LED green or you're basing this on the amount of time the device was on charge? Are you getting any LED indicator at all? If you are still getting an LED display that is a hopeful sign that the device isn't completely dead. When attempting to restart the phone how long are you holding the power button? 5, 10, 30 seconds? Have you held it for a minute or more? Don't be afraid to hold the power button for what may feel like an extended period of time. Even though you are able to pull the battery have you attempted to start the phone while holding the volume rocker up or down? Down will usually give you options associated with resetting the phone, up most of the time these days, simulates a battery pull, even though for your device you can actually pull the battery. I would try both, and don't be afraid to hold the power button a little longer then you think is normal. Also some devices have options associated with holding the home button while powering on the device. You may also want to try that.
    08-16-2014 10:03 AM
  4. achanouh's Avatar
    I have the same issue on my S4 (I337). It was on the charger, I did a reboot command from the menu while it was plugged in then I unplugged it within a fraction of a second from issuing the reboot command, then everything went black and it will not turn on, no LED functionality did everything I can to wake it up, but nothing worked, ex: holding power button, volume up home and the two capacitive button for a very extended time. It will not charge either. If I plug it to my computer, the computer beeps acknowledging that it was plugged in. If I hold the power button combination while plugged in tho the computer the computer will beep again after 3 seconds acknowledging that the phone "may be" switched states. Is there a hardware button I can press to reset it. Of do you have something I can try to wake this sucker up.
    09-13-2014 11:48 PM
  5. KeepItReal's Avatar
    Perhaps borrow someone's battery to see if it's the culprit? There is some circuitry in the battery that 'talks' to the phone. You could take it to your carriers store. They may have some returns that would allow you to borrow a battery to test. If at the carriers store, and the battery from the returned phone works, they may let you keep that battery, and put your bad battery in the box to be returned to the manufacturer. Good luck.

    Posted via the Android Central App
    09-14-2014 01:05 AM
  6. achanouh's Avatar
    I have taken the battery out and tried to wake it up using the wall charger only, that didn't work, it is still in a coma. No LED nothing.
    09-15-2014 09:57 AM

Similar Threads

  1. Replies: 4
    Last Post: 09-07-2014, 06:22 PM
  2. S4 not charging when using video adapter
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-17-2014, 07:59 AM
  3. Help! Galaxy S3 won't charge
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 08-16-2014, 01:11 PM
  4. Fb logs on galaxy s5
    By Ruxika in forum Ask a Question
    Replies: 0
    Last Post: 08-16-2014, 08:49 AM