1. AC Question's Avatar
    I have a Motorola Razr HD XT926, running 4.4.2. Computer is Win7 64bit.

    Neither PTP or MTP will work and they have worked previously, same phone/cable/computer. It was a while ago, so I cannot pinpoint what has changed. This phone will work connecting to another computer on Win7.

    The Motorola Device Manager drive will show up and allow that to install. This only says "There are no updates for your device at this time. Current Version: N/A"

    Device Manager has consistently brought "This operation requires an interactive window station." when searching for drivers.
    08-19-2014 02:17 PM
  2. SpookDroid's Avatar
    This sounds like a driver issue. I'd try deleting all drivers for your Moto Device from the Device Manager in Windows, reboot, and re-install the Moto Software. I know that helped me once but on a Samsung.
    08-19-2014 02:25 PM
  3. sarge46's Avatar
    I've uninstalled the Motorola software and uninstalled the MTP device from device manger.
    After the computer restarts, it tries to download the MTP drivers but fails again.
    The drivers for this device are not installed. (Code 28)

    This operation requires an interactive window station.

    The Motorola Software gives the same error as previous.
    08-19-2014 02:55 PM
  4. Rukbat's Avatar
    Try a different USB port on the computer. (Don't use a USB hub - connect directly to the computer.) If the phone connects to a different computer it's not a problem with the phone, it's a problem with the computer.
    SpookDroid likes this.
    08-19-2014 03:02 PM
  5. sarge46's Avatar
    I understand its a computer problem, I just cant seem to find the problem.

    I've plugged it into different ports and the MTP driver still cannot be found.
    08-19-2014 05:14 PM
  6. SpookDroid's Avatar
    Have you tried to run the Motorola Installer on Safe Mode in Windows? I don't think it'll just find the driver, I think you need to install the Moto software, but if it's not letting you...
    08-19-2014 05:29 PM
  7. B. Diddy's Avatar
    Did you recently run Windows Update? The most recent slew of updates included some erroneous ones that caused problems. It caused my desktop to start recognizing my Nexus 5 as an "Acer ADB" device. I had to do the following to correct it: http://forums.androidcentral.com/goo...ng-device.html

    And here's the article describing the various issues: Microsoft pulls its August Windows update after users report crashes | PCWorld
    08-19-2014 05:47 PM
  8. sarge46's Avatar
    No, this issue with MTP/PTP has been going on for some time now. Last windows update was 7/14, but I had same problems before that as well.

    I tried going into safe mode, uninstalling MTP and reconnecting the device, and using the Moto device manager. Same error messages as above.
    08-19-2014 10:11 PM
  9. sarge46's Avatar
    The MTP drivers are the same version and date on my second computer as the one having issues. I really cant find where the issue is. Not a single MTP device can connect.
    08-20-2014 02:40 PM
  10. low_battery's Avatar
    did you ever solve this? i have googled this to earths end and back and still havent been able to fix this plague of usb code 28s and code 10s!
    07-27-2016 03:46 AM

Similar Threads

  1. LG G3 Best Backup and Restore app
    By Nunya Biz1 in forum LG G3
    Replies: 13
    Last Post: 11-19-2015, 11:50 AM
  2. tones don't work
    By majicjazz in forum HTC One M7
    Replies: 8
    Last Post: 08-22-2014, 03:35 AM
  3. My Samsung galaxy Tab 3 7.0 will not start
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-19-2014, 01:24 PM
  4. S4 not playing video
    By Bijo Vidyadharan in forum Ask a Question
    Replies: 1
    Last Post: 08-19-2014, 01:23 PM
  5. Replies: 1
    Last Post: 08-19-2014, 12:41 PM