1. AC Question's Avatar
    So i recently got my phone back from my parents. My phone was a T-mobile concord ZTE and i literally tried every single password known to man on my phone and it's still won't open. I tried resetting it but it won't work it only shows an android with a wight box and a arrow coming out of it. And it's pissing me off. CAN SOMEONE PLEASE HELP ME?
    08-21-2014 10:19 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did your parents change the password? Can you ask them? Otherwise, you may want to bring the phone in to T-Mobile and see if they can help you there. Good luck!
    08-21-2014 11:10 AM

Similar Threads

  1. Replies: 12
    Last Post: 02-13-2015, 05:59 PM
  2. I broke my Samsung Galaxy S3 trying to upgrade it
    By AC Question in forum Ask a Question
    Replies: 8
    Last Post: 08-25-2014, 09:29 AM
  3. Phone beeping on boot and other times
    By wickedninja667 in forum LG Optimus Elite
    Replies: 3
    Last Post: 08-22-2014, 11:22 PM
  4. Different Hangouts on Desktop and phone
    By Bill Brinson in forum Ask a Question
    Replies: 5
    Last Post: 08-21-2014, 12:55 PM
  5. phone is messed up...
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-21-2014, 08:48 AM