1. MNC4mykids's Avatar
    I was using my S3 today when a message appeared telling me not to remove the microSD card without first unmounting it. I thought that was odd since I had not been doing anything. I restarted the phone, removed and reinstalled the card without my phone recognizing that there was a card present. I thought it might be a hardware issue so I took the microSD card from my tablet and tried it in the phone and it worked. I next tried the phone microSD card in the tablet and again, it was not recognized. I tried it in an adapter with my laptop and it again did not recognize the card.

    I am assuming that somehow, the card just "died" for lack of a better term. Is there any way I can recover the pic's / files that were on the card? Is there any way to get the card functional again (hopefully short of re-formatting it)?

    Any help is appreciated!!
    08-23-2014 01:13 PM
  2. Rukbat's Avatar
    It depends on what died in the card. There's a whole computer in there - RAM, ROM and a controller (like a CPU). If the controller or RAM died, the manufacturer can take the storage chip out and recover what's stored on it (for about the price of a nice new car).

    If the controller is just not seeing the directory of files, you can try using PhotoRec - CGSecurity Download it (it's free, but worth a fortune), burn it to a CD and boot your laptop with the CD. Plug the SD card into an adapter and plug it directly into one of the USB ports of the laptop (not into a USB hub). If the laptop can find the SD card, PhotoRec can recover any block of data that looks like a file format it recognizes (there's a list of them at the site, and it includes any picture format I've ever heard of).

    If the card is completely unrecognizeable, you won't be able to format it - the computer has to see it to format it (and if the computer can see it, so can PhotoRec). If it's that bad, and it's a SanDisk card, try SanDisk device NOT detected by Windows PC first. If that still doesn't let you get into the card (if PhotoRec doesn't find it, it's not a Windows Registry problem, since PhotoRec doesn't use Windows), contact tech support at SanDisk Contact Information (They're pretty good about replacing cards that go bad.)

    If it's not a SanDisk card ... well, that's why I only buy SanDisk cards.
    08-23-2014 03:30 PM

Similar Threads

  1. Another SD card gone bad
    By eeyore6802 in forum Ask a Question
    Replies: 5
    Last Post: 08-24-2014, 07:17 PM
  2. Hard reset not working
    By newtda513 in forum Google Nexus 7 Tablet (2012)
    Replies: 1
    Last Post: 08-23-2014, 10:16 PM
  3. Micro SD mem card corrupts S5 start up??
    By HannahR in forum Ask a Question
    Replies: 1
    Last Post: 08-23-2014, 03:48 PM
  4. Sprint Samsung Galaxy SII Android Phone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-23-2014, 03:45 PM
  5. Samsung Galaxy S4 SGH-I337 stuck with error message
    By Soraka in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 08-23-2014, 11:07 AM