1. grassgazer's Avatar
    The Google account I initially registered my device with was deactivated by my administrator. I added another account as soon as I recognized the primary was deactivated, but now I can't update any of my Apps. Every time I try to update an App I get the error message "could not retrieve information from server [RPC: S - 3]". I tried clearing the cache on all my Apps and then turning it on and off again to no avail.
    08-24-2014 12:24 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! If the apps that are on the phone were installed using your prior Google account, then you might have trouble updating them, since they're not associated with the new Google account. I would uninstall the apps (from the Settings>Apps) menu, then go to Google Play and reinstall them. They should now be associated with your new Google account, and should therefore be updateable as well.

    If you had paid apps on the old Google account, I'm not sure if you'll be able reinstall them for free using the new account--you'd probably have to purchase them again, since it's a different account. You could contact Google Play Support about this: https://support.google.com/googleplay/?hl=en
    grassgazer likes this.
    08-24-2014 01:45 AM
  3. grassgazer's Avatar
    I tried uninstalling and reinstalling, but when the app was reinstalling I got "Error retrieving information from server. [RPC:S-7:AEC-0]"
    08-24-2014 10:07 PM
  4. B. Diddy's Avatar
    What device do you have? I would also suggest wiping the cache partition, but need to know what the device is.
    grassgazer likes this.
    08-24-2014 10:10 PM
  5. grassgazer's Avatar
    It's an LG G2
    08-25-2014 09:44 PM
  6. B. Diddy's Avatar
    The problem with LG phones is that they don't let you access the Recovery Menu to wipe the cache partition if you're unrooted. You'd have to root the phone and install a custom recovery.
    grassgazer likes this.
    08-25-2014 11:01 PM
  7. grassgazer's Avatar
    Is this the only way to fix my phone and keep the Apps I have already?
    08-28-2014 09:47 PM
  8. grassgazer's Avatar
    I found a tutorial, but it seems a little invasive (forum.xda-developers.com/showthread.php?t=2448887) . Is there any other way?
    08-28-2014 09:53 PM
  9. B. Diddy's Avatar
    I forgot to mention this before--try going to Settings>Apps>All, select Google Play Store, Clear Cache/Data and Force Stop. Now open it and try again.
    08-28-2014 11:00 PM

Similar Threads

  1. Which Messaging App?
    By jhnnyblze2000 in forum LG G3
    Replies: 167
    Last Post: 02-22-2015, 09:30 PM
  2. Pin on s3 home screen is not accepting / working
    By smkhajuria in forum Ask a Question
    Replies: 1
    Last Post: 08-24-2014, 01:48 AM
  3. Why Install Android on your PC
    By rmadrid20 in forum Ask a Question
    Replies: 0
    Last Post: 08-23-2014, 11:26 PM
  4. chrome freezing when scrolling on android central mobile site..
    By killabee44 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 08-23-2014, 10:40 PM
  5. Anyone accomplished AW on BB10?
    By bbhybridchris in forum Android Wear
    Replies: 0
    Last Post: 08-23-2014, 09:02 PM
LINK TO POST COPIED TO CLIPBOARD