1. dan123287's Avatar
    I can't find anything that will explain this, basically I'll add a contact to my phone, give it a minute then the contacts gone after that and I'm just back with the number in my text app, in this case hangouts, if anyone has an answer to this cause its really odd, thanks for reading!

    Posted via the Android Central App
    1341 likes this.
    08-26-2014 07:46 AM
  2. srkmagnus's Avatar
    I can't find anything that will explain this, basically I'll add a contact to my phone, give it a minute then the contacts gone after that and I'm just back with the number in my text app, in this case hangouts, if anyone has an answer to this cause its really odd, thanks for reading!

    Posted via the Android Central App
    Go into system settings > accounts > Google. Make sure contacts is sync'd. Also, go back into system settings > applications > sort by all > Hangouts. Clear the cache and see if that helps.

    Let us know if you have further questions.
    08-26-2014 09:38 AM
  3. dan123287's Avatar
    Contact syncing doesn't seem to be working, I also cleared the cache and still nothing

    Posted via the Android Central App
    08-27-2014 06:39 AM
  4. dark1003's Avatar
    Are you saving your contacts on the people app?
    Try going to the people app > contacts to display and check that your google account is selected.

    Posted via the Android Central App
    08-27-2014 07:17 AM
  5. Nick Peake's Avatar
    The answer from srkmagnus helped me to get to where the problem is, but not how to solve it. In my Google account Contacts has an exclamation symbol, and a message at bottom of screen which says "Sync is currently experiencing problems. It will be working again shortly." But nothing seems to be happening, and the problem of my Moto G not saving new contacts has been going on for months since September - it says "last synced 05/09/2015."
    02-22-2015 10:47 AM
  6. Nick Peake's Avatar
    Dan, did you ever sort out your problem with contacts not saving because that's my problem too?
    02-22-2015 10:50 AM
  7. grace75's Avatar
    The answer from srkmagnus helped me to get to where the problem is, but not how to solve it. In my Google account Contacts has an exclamation symbol, and a message at bottom of screen which says "Sync is currently experiencing problems. It will be working again shortly." But nothing seems to be happening, and the problem of my Moto G not saving new contacts has been going on for months since September - it says "last synced 05/09/2015."
    I've got the same problem. Tried all the suggestions and none work. Just won't sync.
    07-04-2015 01:36 PM
  8. Souren15's Avatar
    Dear,
    Is there any other option or how to save a contacts in my phone memory when there is no internet connection.
    05-21-2016 12:23 PM
  9. Watchdog1964's Avatar
    I've got the same problem. Tried all the suggestions and none work. Just won't sync.
    I have the same problem on a moto G3 and it's driving me nuts. Doesn't matter where I add contact be it in contacts, outlook, or WhatsApp a minute later it's gone
    07-28-2016 06:59 AM
  10. zdubs's Avatar
    Having the same issue... I'm pretty it's because I dont want to save my contacts in google and am trying to use Outlook instead. Can someone please help me fix this issue?
    07-29-2016 12:09 PM
  11. Blueraven369's Avatar
    I have had this same nightmare!! Spoke to technical support who suggested deleting Google app then reinstall ... That didn't work. Then factory reset ... That didn't work. What seems to be working now is that I have deleted my mail app and numbers seem to be storing locally. Bit of a nuisance that I can not have a mail app but at least I can check mail through browser, couldn't find any other way to save numbers!! Hope this helps. Good luck!
    11-16-2016 06:58 AM
  12. VIPER9433's Avatar
    I can't find anything that will explain this, basically I'll add a contact to my phone, give it a minute then the contacts gone after that and I'm just back with the number in my text app, in this case hangouts, if anyone has an answer to this cause its really odd, thanks for reading!

    Posted via the Android Central App
    THERS a workaround for the problem u r facing. I recently bought moto G4 Plus and faced the same issue, however I found the concrete solution for the same

    Issue: contacts name disappear /don't get saved /synced automatically after few seconds (50sec)approx/ re open cell etc

    Workaround : so first go to settings /accounts/google press home button now go to the number which needs to be saved as contact do the needful and click on okay tickmarck and quickly jump to previous setting/Google screen and click on dotted line on top right and hit (sync now ) u r last contact is saved now repeat this everytime for saving contacts
    Reason for me is that contacts not getting synced as one hit save contact, so yeah it's a bug on moto devices hope this gets fixed on nougat update hope this helps.
    I advice moto support to patch this up and or make sure this doesn't carry forward in Nougat update
    P.S. moto lennovo speed up nougat ota release
    11-17-2016 02:45 AM
  13. VIPER9433's Avatar
    Deleting won't be necessary follow my procedure it's tedious but world like a charm
    11-17-2016 02:47 AM
  14. VIPER9433's Avatar
    Even i use outlook for contact sync and my workaround works well with almost all accounts . Give it a try
    11-17-2016 02:50 AM
  15. VIPER9433's Avatar
    Follow my procedure . it works !!
    11-17-2016 02:51 AM
  16. CivDes2k3's Avatar
    Follow my procedure . it works !!
    Hey, everyone! New to the board - happy to meet you.

    VIPER, I tried your method on my Moto G4. It worked for about 10 minutes, then reverted back. It's like the sync for outlook is only working one way?

    I've been reading some other posts regarding this issue - it doesn't seem to be limited by just the Moto brand. Could it be something causing conflict between Android and Outlook?
    12-04-2016 10:07 AM
  17. Chris102938's Avatar
    The source of the problem for me was saving as an outlook contact rather than a Gmail contact. I solved that by going to outlook app>settings>click email address>turn off sync contacts
    12-04-2016 10:12 AM
  18. Bill Hill13's Avatar
    Go into system settings > accounts > Google. Make sure contacts is sync'd. Also, go back into system settings > applications > sort by all > Hangouts. Clear the cache and see if that helps.

    Let us know if you have further questions.
    My my Moto G I like I've only had it for 5 days I only have about 4 days left it stopped working you won't let me set it up again it keeps making me go back to the same thing I've contacted Consumer Cellular and also Google I'm checking my personal information everything works out but it won't accept it would you please help me in any way you possibly can thank you so much Bill Hill you can only reach me at the home phone number because the cell phone is not working it's [phone number redacted by Mod] this cell phone number is [phone number redacted by Mod] new cell phone is not working please help me I have all simers disease I can't do this by myself please anybody that calls have for me racing with Alzheimer's thank you Bill Hill remember you can only call me at the home phone number [phone number redacted by Mod] thank you so much any help would be pleased and in gratitude but make sure whoever called and I understand about Alzheimer's the phone was working perfectly one of the workers at Consumer Cellular had me reset it and go back in and I can't get past the settings don't know what to do if Motorola can call I'm sure I'm very happy with the Motorola G I don't really want to get rid of it but please try to help me only have 4 days left thank you Bill Hill
    12-19-2016 05:11 PM
  19. B. Diddy's Avatar
    Welcome to Android Central! Please don't post your phone number in the forums, for your safety and privacy -- I edited them out.

    It's difficult to understand what your main issue is. Can you clarify? And remember that this is an independent community forum -- we have no direct affiliation with any hardware, software, or wireless company.
    12-19-2016 05:30 PM
  20. Deckard1's Avatar
    Go into system settings > accounts > Google. Make sure contacts is sync'd. Also, go back into system settings > applications > sort by all > Hangouts. Clear the cache and see if that helps.

    Let us know if you have further questions.
    I think i have a fix for this.
    I struggled with this for weeks and then accidentally realised that I had disabled a couple of intrusive Google programs like hangouts etc. I enabled them again and restarted my phone and all of the contacts have saved ever since. Hope this helps someone.

    Deckard.
    02-10-2017 05:03 PM
  21. PhilWarblood's Avatar
    I've had some luck with creating contacts in Messenger by tapping on the person's icon, then selecting add contact >> create new contact, filling out the info and then at the very top (by default, mine wants to save to both Outlook and Gmail), selecting save to my Gmail address only.

    It's been several hours now and I rebooted my phone earlier.

    Nothing else that I've tried has lasted this long.
    belodion likes this.
    05-16-2017 07:58 PM

Similar Threads

  1. Moto g
    By Manan Juneja in forum Ask a Question
    Replies: 2
    Last Post: 08-26-2014, 07:30 PM
  2. Albums on Galaxy S3 won't open
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-26-2014, 06:40 PM
  3. moto g
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-26-2014, 09:41 AM
  4. Galaxy S3 won't let me override auto correct.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2014, 05:18 PM
LINK TO POST COPIED TO CLIPBOARD