1. AC Question's Avatar
    I've had my Galaxy S3 for about a year now without trying to sync it to my computer. Today I decided to sync it to kies. Kies asked to update my phone, and knowing it was long overdue I accepted. The update failed, so I tried recovery mode. Also failed, then I tried to upgrade/initialize the firmware. And I got the error message "This Device's version cannot be updated". I searched online but no one seems to be having the same issues I am. I haven't done anything to this phone other than download apps from the google play store. I don't know what else to do. Please help.
    09-07-2014 03:44 AM
  2. Haseeb Rehman's Avatar
    Are you able to use your phone? If yes, then you have an option to root your GS3 and install a new custom rom on your device with the latest android version and according to your taste.
    09-07-2014 04:19 AM
  3. grace1ess's Avatar
    No, I cannot it is in odin mode saying "Firmware upgrade encountered and issue. Please select recovery mode in Kies and try again."
    09-07-2014 11:01 AM
  4. Haseeb Rehman's Avatar
    Try to Google that problem. Or just look up the method to flash a stock rom using Odin.
    09-07-2014 02:41 PM

Similar Threads

  1. List of apps that can write to SD card in KitKat?
    By John728 in forum Legacy Android & Other OS's
    Replies: 2
    Last Post: 09-08-2014, 04:46 PM
  2. Remove photos off Nexus 5 (Google Drive issues)
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-07-2014, 02:45 PM
  3. Replies: 1
    Last Post: 09-07-2014, 02:41 AM
  4. Moto E rejects my headphones.
    By akiwicat in forum Ask a Question
    Replies: 0
    Last Post: 09-07-2014, 02:37 AM
  5. How to connect my Android app to a web service?
    By SUPERUS8R in forum Ask a Question
    Replies: 0
    Last Post: 09-07-2014, 02:13 AM