1. AC Question's Avatar
    Hey, I have a ZTE v795 and I've had it for about 2 months, in those months the phone has worked perfectly... Until today, I installed a game called Eredan Arena, after a couple of matches I got bored and deleted it, I kept looking for new apps and games and after deciding on one I tried to install it (from my pc on the website). The play website said it was compatible with my phone and I clicked install.

    When I went to my phone a little notification that the download had failed popped up, it usually does that and I just open it up on the app and download again from there, but this time a little message came up that said "Your device is not compatible with this version". I found it weird but shrugged it off, I then decided to download a different game, one that I had installed before. I went to my app history on the Play store app and you know how it shows the prices of the app in the bottom left corner, well most of them had no price, only a select few had it in them. This means that the once with no price are not compatible with the phone. But these were all apps that I had installed on the phone before (some even this same week).

    Anyway, long story short (can I still say that after that wall of text that got me nowhere?) Most apps are now "uncompatible" with my phone. Even apps that I installed this same week. EVEN THE APP THAT I DOWNLOADED TODAY.

    I looked around and found other people with the same problem followed the steps that some showed to fix the problem, nothing worked. Decided to do a factory reset thinking it would work. And it didn't. I reset it, entered my google account again, and the same problem happened, when I enter the google play store app it is mostly empty, with only 5 or so apps showing up. When I try to download let's say Whatsapp, which was downloaded before I did the reset and was working perfectly, it says that it is now not compatible.

    It is driving me crazy. I need some help here.

    Keep in mind that my phone (as far as I could search) can't be rooted, I've tried and I have not been able to do it (with the tools available online at least).

    Anyway, anybody got a clue as to what's going on and what could solve my problem?

    TL;DR : All Apps are now not compatible with device, even apps that worked the same day. Data/cache clear didn't work. Factory reset didn't work. Crappy phone. Losing mind slowly.
    Aztec6913 likes this.
    09-08-2014 08:12 PM

Similar Threads

  1. Replies: 88
    Last Post: 11-21-2014, 09:25 PM
  2. Your Thoughts On The Whole Linus Tech Tips Reviewing WP
    By A895 in forum General News & Discussion
    Replies: 4
    Last Post: 09-09-2014, 02:13 PM
  3. SG3 works fine except the screen is blank.
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-09-2014, 08:05 AM
  4. HTC ONE M7 4G not starting
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-08-2014, 10:29 PM
  5. Social Media Is Changing Your Brain
    By dctokyo in forum The Android Central Lounge
    Replies: 0
    Last Post: 09-08-2014, 08:01 PM