1. AC Question's Avatar
    Hello Members,

    I am facing a peculiar problem in my Nexus 5.

    For the last two weeks; it's taking ages to charge fully to 100%. Typically it takes 2 days to charge from 20% to 100%.
    The battery otherwise seems to be working fine, it does n't drain fast.

    From yesterday, the battery seems not to charge at all. I had forgotten to charge it and made phone calls/3G Viber messages causing the battery to die completely.

    Since then, I am trying to charge it. On connecting to the AC Mains using the original AC Charger, the LED blinks red for a few minutes before dying off.

    I am also not able to go to the service mode by pressing the Power and Volume Up/Down switches.

    Can you help?

    I don't have any strange Aps. I only have the usual ones like Whatsap and Viber.

    Thanks in advance,

    09-17-2014 02:14 AM
  2. Arijit Bhaduri's Avatar

    I managed to switch on my Nexus 5 by pressing the Volume Up/Down and Power buttons at the same time and going to the Start mode.

    However my original problem persists- charging takes place slowly.

    Tried all tricks - multiple chargers etc.

    It looks to be a software issue. Have not tried Factory resets as have important Whatsap messages. Will try that later and report.


    09-17-2014 02:55 AM

Similar Threads

  1. Nexus S
    By AC Question in forum Ask a Question
    Replies: 9
    Last Post: 09-17-2014, 09:43 PM
  2. Samsung s5 Google Play Error
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 01:49 AM
  3. Can't find the movie I downloaded from Google play
    By Muffdawg69 in forum AT&T Samsung Galaxy Note 3
    Replies: 3
    Last Post: 09-17-2014, 01:40 AM
  4. nexus 7 backwards screen after developer settings
    By androidthings01 in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 01:36 AM