1. AC Question's Avatar
    Is anyone else having a problem with the Samsung Gear manager V2.2.14090599 crashing thus making your Galaxy gear 2 a bit useless.

    Anyway to fix this?
    09-17-2014 04:51 AM
  2. DTM2014's Avatar
    I'm having the same problem. I casually let the Samsung Gear App update this morning to V2.2.14090599 and now it crashes every time I attempt to open it - With Unfortunately Gear Plugin has stopped.

    I've attempted to clear data and cache of all Gear and related apps (which factory reset the Gear itself). Now it's factory standard, and I can't launch the app to customise or even you it!!!

    Is this a wide spread issue?
    09-17-2014 06:30 PM
  3. MeanM0F0's Avatar
    Same happening here, brand new S5 too
    09-18-2014 01:50 AM
  4. prubin's Avatar
    Works for me. What does it do better?
    09-18-2014 06:57 AM
  5. Michael Lynady's Avatar
    Problems everywhere - sad thing is this update was for the gear circle headphones - so to add the circle they screwed up the gear-lol

    Posted via the Android Central App
    09-18-2014 02:02 PM
  6. prubin's Avatar
    Horrid battery life.
    09-18-2014 02:11 PM
  7. Geraldo Fonseca's Avatar
    Same here. After the latest update it keeps crashing. Already tried to reinstall from scratch and still the same.
    daniel.michael4724 likes this.
    09-18-2014 06:00 PM
  8. astromuzza's Avatar
    Same problem with me and this update and I get the following message when I try to run the Gear Manager app - Unfortunately, Gear Plugin has stopped.

    Very frustrating!
    09-18-2014 06:40 PM
  9. wharlie's Avatar
    I uninstalled the gear manager and found a gear manager apk file and installed that so now im back to previous version. All good
    09-18-2014 07:31 PM
  10. Geraldo Fonseca's Avatar
    I fixed it by downloading the previous version from goo.gl/zWRRrD (it's media fire. the version is 2.1.14071502)
    09-18-2014 09:30 PM
  11. DTM2014's Avatar
    Ok, cool. So I've downloaded and installed the previous version no problem, BUT the second I launch it, it says it needs to update. Options are Ok or Cancel.
    If you Cancel, the app exits. If you OK, it proceeds to update... then crash (obviously).

    How do you run it, without updating it?
    09-19-2014 05:53 AM
  12. Geraldo Fonseca's Avatar
    After rolling back to the previous version it asked me to update again. No way to get rid of it. Is Samsung away of its epic fail? Such a shame.
    09-19-2014 07:36 PM
  13. DTM2014's Avatar
    If you go to the Settings of the Galaxy App store and tell it not to auto update your apps, it seems to let you use Gear Manager.
    Every now and then, when you launch Gear Manager, it does try to force you to update. But if you just cancel and relaunch (maybe even a few times), it seems to stop asking. At least for a while.
    Not the best solution, but may get us by until they fix the latest update.

    Does anyone have any word on a time frame for the fix? Any news?
    09-20-2014 05:28 AM
  14. Michael Lynady's Avatar
    I went and deleted everything associated with Gear manager and all Gear apps - reset watch, downloaded Gear manager, set up watch again and everything is working fine

    Posted via Android Central App
    09-21-2014 02:12 PM
  15. Geraldo Fonseca's Avatar
    I'll give a try. Anyhow, I would be already fired if I had delivered such a crap update.

    Just gave it a try. It didn't work

    Thank you mate.
    09-22-2014 06:34 PM
  16. Jeff Wittich's Avatar
    I uninstalled Gear Manager on the S5 and reset my Gear 2. I then re-installed Gear Manager and tried to set up the Gear 2 again. When I try to connect, I get an Install window on the phone indicating it would like to install additional software and a white error pop-up appears on the phone stating, "Download URL not avaiable, Can't launch Plugin!" (the typo is real - I copied verbatim) followed by a Notice stating "Unable to connect to the Gear. Connecting to the Gear is not supported by your mobile device or your software needs to be updated. Check that your mobile device is able to connect to the Gear, then update your mobile device software."
    Samsung Gear manager V2.2.14090599 crashes-screenshot_2014-09-22-20-53-17.png
    Sounds like there is a plug-in that Samsung Gear would like to install but is not available at the correct address anymore.

    My Gear 2 worked a few days ago before the software update was pushed.

    Any suggestions besides waiting for Samsung to fix this piece of crap?
    09-22-2014 10:52 PM
  17. miniberto's Avatar
    same problem here!!! help please!!
    09-23-2014 02:31 AM
  18. martin_coxy's Avatar
    I had exactly these symptoms and this worked for me after a lot of other resets and messing with missing some of the steps:

    (actually not these symptoms above but those described earlier b other.. Gear Manager crashes with "Unfortunately plugin has stopped" and the watch is pretty much bricked..

    Deleted Gear Manager
    Ran Android Assistant to clear the cache
    Unpaired the phone and Gear (I have a feeling this is the critical part)
    Reset the watch from the on board setup menu
    Rebooted the phone
    Downloaded and installed Gear manager
    Paired with the watch from within Gear Manager (For no real reason, I also think this may be critical)

    ...and now it works like a dream.

    If it's this easy why isn't Samsung publicising this??
    09-23-2014 10:40 AM
  19. Cochabambinito's Avatar
    For installing 2.1 and don't be replaced by 2.2:
    1. disconnect from internet. Turn off wifi and 3G.
    2. Let the Install additional software do the job _(it's software of 2.1)
    3. Do the pairing with the wath.
    3. After finishing, you'll strt to get FC fo goprovider. Install this one: forum.xda-developers.com/showthread.php?t=2758364 (goprovider-signed-20140529.apk )
    4. In Configuration of Gear Manager, uncheck the Automatic Update.
    5. That's all. You have the 2.1 without errors and normal battery life (3 days)

    **** BUT ***** This version of Gear Manager doesn't enable the Notification for all Apps... So, no Whatsapp, skype, Fb, nothing. So, what solution for that??
    11-26-2014 01:18 PM

Similar Threads

  1. Hard bricked samsung galaxy sl i9003
    By mihir v in forum Ask a Question
    Replies: 0
    Last Post: 09-17-2014, 04:06 AM
  2. Phone stuck on samsung logo
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 03:31 AM
  3. samsung s4 will only charge when turned off
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-17-2014, 03:26 AM
  4. Samsung s5 Google Play Error
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 01:49 AM
  5. samsung galaxy s3 charging problem...
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-17-2014, 01:01 AM