1. AC Question's Avatar
    I have a galaxy s3 and recently I have been getting a ( invalid uri ) message when trying to update 5 apps from google play store. Does anyone know why this is happening or how to fix it......thanks
    09-25-2014 06:18 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try going to the App Manager, select Google Play Store, and Clear Cache/Data, then Force Stop. Now try again.
    09-25-2014 11:32 PM
  3. kjkearney's Avatar
    I have done what you have said to do, but still experience it, even on a replacement phone. I've tried a cleaner, using a new gmail account, even hooking it up to my computer, and nothing worked!
    10-20-2014 10:41 PM

Similar Threads

  1. Is there a Bluetooth headset for the Note 3 with great range?
    By browetally in forum Samsung Galaxy Note 3
    Replies: 7
    Last Post: 09-26-2014, 10:55 AM
  2. How do I put the date on my pictures?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2014, 08:02 PM
  3. What happend to my favorites showing on my toolbar?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-25-2014, 06:19 PM
  4. App permission manager
    By marios1441 in forum General News & Discussion
    Replies: 1
    Last Post: 09-25-2014, 06:11 PM
  5. How do I uninstall TWRP on rooted phone?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-25-2014, 06:07 PM