1. CaptainPackers's Avatar
    Thanks. Clearing the Google Play Store app cache and data worked for me.
    02-25-2015 08:33 AM
  2. CaptainPackers's Avatar
    Even I had the same bug.
    Try this
    1 Go to seetings
    2 Application and find you google play store app and clear cache the data.
    I tried this and its successful
    Thanks! This worked for me!
    02-25-2015 08:35 AM
  3. Steve Spence's Avatar
    uninstalling the updates did not clear the problem for me.
    02-25-2015 03:13 PM
  4. thepratikk's Avatar
    Just uninstall the updates of google play service & play store .

    Path = setting - app - google play service - uninstall.

    Best and easy way.
    03-18-2015 11:36 AM
  5. reza_attitude's Avatar
    If your device is rooted just install root uninstaller app then launch the app and find google play service in this app then click on it and hit the reset button... This work will return the google play service to factory setting.... And 99 percent your problem will become solve.... I had this problem too and tried all the way but i dont take any response... But with this method that i test by myself the problem solved easily... I hope your problem become solve too my friends
    03-26-2015 05:36 AM
  6. Tyrell Le Grange's Avatar
    Uninstalll your Google play services and install it again
    03-26-2015 09:57 AM
  7. Bradex's Avatar
    First I uninstalled the updates for the Google Play store and then uninstalled the updates for Google play services. Now everything seems fine.
    To uninstall the updates, go to apps->Google Play Store?Google play services-> Uninstall updates

    I did have to reinstall the updates but everything worked after that.
    Had a similar problem on my Galaxy Note I today. Resolved after this fix. Thanks!
    03-29-2015 03:28 AM
  8. Joe Medina2's Avatar
    04-04-2015 06:10 AM
  9. lyrox abarquez's Avatar
    04-16-2015 10:36 PM
  10. Shitty Boss's Avatar
    yeah, i did a factory reset and can't do anything because everytime i want to accept the terms and go on, it says google play service has stopped
    John P2 likes this.
    04-17-2015 01:44 AM
  11. odkwheat's Avatar
    One of my friends recommended this process and it worked for me: remove your Google account (be sure you have a printed 2 step auth code before you do this) from your phone/tablet. uninstall updates for Google Play services, clear all app data for Google Play services, then re-add your Google account, annoying notification pop-up wont stop showing up until you sign into a service (in my case I signed into the Google Play store app). Hope that helps! That process saved me from having to do any factory reset.
    04-18-2015 08:54 AM
  12. Monique Bost's Avatar
    how to fix my Google service is stop raining all pictures all video Gmail everything as that one it will not reboot itself
    04-18-2015 12:42 PM
  13. mdrobiulhasan's Avatar
    1.Go to setting
    2.Open Apps/Aplications
    3.Click Option Button/Left Button
    4.Click Reset App Preferences
    5.Click Reset Apps

    Hopefully it will work
    04-26-2015 03:05 AM
  14. Dharma Mati's Avatar
    I have a tablet running 4 4 2.I kept getting this annoying error to the point my tablet was unusable.this is how i fixed it.First go to play store settings and disable automatic update of apps.then go to all the google app installed in your phone and do a factory reset.click disable then yes to factory reset.then enable them again one by one.you should be fine.It seems google is screwing us all bigtime nowadays😈PS when you get prompted if you want to install a new update in all google apps just ignore it.never ever ever get updates for google apps.they serioussly screw up your system
    Chris A1494 likes this.
    05-03-2015 11:10 PM
  15. Soulless MZD's Avatar

    I just had this annoying thing myself and the solution is actually really simple, no need to go to any shop or somthing.

    solution: settings --- apps --- google play services --- force stop --- enjoy lolz


    if you cannot find google play services, dont look at downloaded, but look at ALL, surely you will find it.
    05-05-2015 12:31 PM
  16. Ken Johns's Avatar
    I experienced the "Play Services" message following a notified OTA messge of an Important Update. In fact the Important Message was an "Upgrade" to Lollipop. I tried everything to even access my mobile which became accessible only for a few minutes before again showing the dreaded "Play Store /Play Store Services" messages.

    In the end I shoved my contact list and important files to Google Cloud and shut down everything. When rebooting I held down the Volume Control at its lower setting and waited until it restarted in "Factory MODE". I then scrolled down the list of actions to "Clear eMMC" and pressed the On/Off button. The phone eventually started a whole new installation to Android 5 Lollipop and on completion the system updated the Play Store & Play Store Services apps. It was easy to reload my Contact Lists and Files from Google Cloud during the process.

    Now everything works fine. The problem for me and many others is the OTA updates which sometimes never complete properly and cause problems which cannot be resolved by tinkering from the outside.
    05-06-2015 01:45 AM
  17. Alex Choong's Avatar
    I having a note4 clone mobile.
    Isn't that google play service or google play store didn't works for any clone set??
    beside I also have a original set for Samsung galaxy A5 now.
    05-12-2015 09:52 PM
  18. Samuel Crawford's Avatar
    I can't a connection to Google play store.
    05-29-2015 11:29 PM
  19. Oliver Watkins's Avatar
    How are iPhone these days? I am thinking of switching to an iphone. This google play services error has caused such a cluster**** on my phone, that i am seriously thinking of ditching android. Nothing works to fix this problem, and it is such a joke that no one can explain why this error is happening. Does android actually test their products before they ship them out?
    05-30-2015 09:24 AM
  20. lagranebin 77's Avatar
    Please help 😃
    06-03-2015 07:16 AM
  21. hitesh1999's Avatar
    Did you try CWM Recovery and wipe out all the data and Clear cache and uninstall all the updates of google play services AND THEN REBOOT IT I HOPE IT WILL WORK
    06-03-2015 02:10 PM
  22. KittyKat_31's Avatar
    It happens to me too. It always pops, unfortunately, Google play services has stopped during the update of that service. It always happens to my cherry mobile pulse mini
    06-04-2015 02:46 AM
  23. 07666412800's Avatar
    How to Fix Unfortunately Google Play Services Has Stopped
    06-07-2015 03:01 AM
  24. Mohamed Mohamed14's Avatar
    Close the location services
    06-07-2015 02:53 PM
  25. Hossein Kaabi's Avatar
    I had the same problem , i tried to use old backups and restored the phone but didn't help.
    So I tried to disable location services and then problem gone.
    I think the location services is working like a timer getting the current location every second or so and probably cause the popup saying "google pay..."
    For me disabling location services fixed the problem.
    Setting > Location > Off
    06-14-2015 07:48 AM
114 1234 ...

Similar Threads

  1. Replies: 1
    Last Post: 10-05-2014, 11:08 AM
  2. Why is my battery draining on my LG G2?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-05-2014, 01:44 AM
  3. Replies: 1
    Last Post: 10-05-2014, 01:43 AM
  4. How do I change SNote text defaults on Note 2?
    By 2canucks in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 10-04-2014, 10:38 AM