1. AC Question's Avatar
    I have just recently bought the Pipo U7 and instantly after downloading a few apps hit the 'insufficient storage available' message which I found strange because it's meant to have 16Gb of storage. Seems it has two storages which a number of tablets I've come across do have but this one won't allow me to transfer any apps to the internal SD card which has 12.4Gb free, when I go onto settings>appmanager>anyapp there isn't even an option to move it... Is the device faulty or am I missing something big? I've tried factory resetting it bbut that made no difference - could it be a partitioning (or whatever it's called) issue? Please help... For he moment I'm stuck with a gig of memory :\
    10-06-2014 12:47 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Not all devices support the ability to move apps to SD. You may need to root the device (if possible) and use an app like App2SD.

    Older devices partition their memory into multiple areas, which can lead to more limited app storage. See this guide for more info: http://forums.androidcentral.com/amb...-warnings.html
    10-06-2014 01:34 PM
  3. Rukbat's Avatar
    Also be aware that:

    Not all apps can be moved to the SD card.

    Many apps that seem to move to the SD card just don't work right when run from it - they only run right when run from internal storage.

    Many apps that can be moved to the SD card only have parts moved - the rest stays in internal storage.

    When an app is moved, fully or in part, a link (or more than one, if more than one part is moved) is written to internal storage, using up some internal storage space (Android expects apps to be in internal storage, so that's where it looks), so you don't gain as much space as you're expecting to.
    B. Diddy and Ivan Reyes17 like this.
    10-06-2014 01:56 PM
  4. alastairjake96's Avatar
    (I'm the one who proposed the question). 1) can't seem to find any rooting software for it. 2) I tried with apps that I knew supported the transfer 3) there is literally no button for the SD card, it should be greyed out if the action was unavailable.
    10-06-2014 02:10 PM
  5. B. Diddy's Avatar
    So it is likely that the phone just doesn't support the action.
    10-06-2014 02:28 PM
  6. alastairjake96's Avatar
    So I've been double crossed basically considering it only has 1Gig of usable memory. Its android 4.2.2 if that makes a difference... Any suggestions/solutions?
    10-06-2014 02:41 PM
  7. B. Diddy's Avatar
    My suggestions are in the guide I linked in the previous post. I always recommend getting a device with the most internal storage you can afford. 4 GB of internal storage always means about 1 GB available to the user, which is hardly good for anything if you intend to install a bunch of apps.
    10-06-2014 02:45 PM
  8. alastairjake96's Avatar
    10-06-2014 02:47 PM
  9. alastairjake96's Avatar
    This help?
    10-06-2014 02:48 PM
  10. alastairjake96's Avatar
    My suggestions are in the guide I linked in the previous post. I always recommend getting a device with the most internal storage you can afford. 4 GB of internal storage always means about 1 GB available to the user, which is hardly good for anything if you intend to install a bunch of apps.
    As far as it advertised it says it has 16Gb of internal memory!
    10-06-2014 02:54 PM
  11. B. Diddy's Avatar
    Sorry, I was thinking of a different device when I said 4 GB. But your storage screen confirms what I was thinking--that the device's 16 GB of memory is partitioned into a 1 GB partition used for app installation called "Internal Storage," and then a 12.6 GB partition called "Phone Storage" which acts like an "internal SD card" (which is often how it's referred to in other devices). It's an old way of doing things that allows the device to be mounted on a computer as an actual external hard drive (only the "Phone Storage" partition would show up), but requires the app installation partition to be separate (and typically much smaller). I describe it in more detail in the guide I linked previously--give it a read if you haven't already.
    10-06-2014 02:57 PM
  12. alastairjake96's Avatar
    OK so why do both have an 'application' section if only one is designated to store apps?
    10-06-2014 03:02 PM
  13. B. Diddy's Avatar
    Apps can actually utilize the internal SD to store certain pieces of data, regardless of the ability to "move app to SD." The app data in the bigger partition might be limited to things like photos.
    10-06-2014 03:05 PM
  14. alastairjake96's Avatar
    So any suggestions on how to re-partition the internal SD?
    10-06-2014 03:07 PM
  15. alastairjake96's Avatar
    I know a friend of mine and his tablet has a similar layout (two storages; one large, one small) and same android version but his device sees it as an SD card and allows him to transfer the apps between the two storages
    10-06-2014 03:10 PM
  16. B. Diddy's Avatar
    Repartitioning, if possible, will require root. That's beyond my scope of knowledge. Regarding your friend's tablet, I mentioned before that some devices have the ability to move an app, and some don't. Yours doesn't seem to have that function. Sorry!
    10-06-2014 03:14 PM
  17. alastairjake96's Avatar
    That's rediculous, thank you for replying so promptly, I guess I'll be going down the rooting option :s . I'll post on here if I find a fix, whether that be rooting or by another means.
    10-06-2014 03:34 PM
  18. alastairjake96's Avatar
    As an update I got an external SD card and can transfer apps to that... Does this change anything?
    10-08-2014 04:31 PM
  19. B. Diddy's Avatar
    That's interesting--in my experience, devices typically can move apps to an Internal SD rather than an External SD. But perhaps yours is set up the other way around. If you can move part of an app to the External SD, then go ahead. Just remember to Unmount the card first if you ever need to remove it (in Settings>Storage).
    10-09-2014 01:20 PM
  20. alastairjake96's Avatar
    OK I'm getting somewhere. Been in contact with the English speaking Pipo customer helper and she has sent me a firmware upgrade to flash on my device. Having a couple issues with the tool to actually flash it at the moment but if it works I'll post again.
    11-06-2014 02:26 AM
  21. alastairjake96's Avatar
    Finally managed to flash the KitKat firmware update which has doubled the amount of memory I can store apps on the teblet internally. I would then conclude it is to do with partitioning. It took a long time and it's not a perfect fix but I'm happy with it.
    12-03-2014 06:46 AM
  22. KeepItReal's Avatar
    When Verizon has a free tablet offer, they are selling you a product designed for Verizon called the Ellipses 7, which has application space of 1gb. The refreshed model, called Ellipses 8 (clever, huh? ) has more application space. They apparently install the pre loaded apps into this same space! ! so users will reach 'no space' quickly. I think a recent update helped a little. What i did to help someone was going into Settings, Application Manager, swipe over to All and going into some of the stock apps that they probably won't use and delete the cache and data first, then select uninstall to uninstall that apps last update, then disable. This will free up a lot of that app space. I did this for Hangouts, Google +, Google Books, Movies, etc. Disabling stops the Playstore from auto updating the app. When you install an SD for more storage, make sure the Camera settings default storage goes to the SD card. When downloading files, such as PDF's, you may want to move those files to the SD card with a file manager of your choice. I use Astro.

    Posted via the Android Central App
    12-03-2014 07:12 AM

Similar Threads

  1. Why am I unable to download an app?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 01-25-2015, 07:28 PM
  2. Why can't I delete some files from download folder?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 11-11-2014, 02:26 PM
  3. Ever had a great phone you just couldn't gel with?
    By robsawalker in forum General News & Discussion
    Replies: 17
    Last Post: 10-11-2014, 06:55 PM
  4. Is it too late to get the Nexus 5?
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 10-06-2014, 05:38 PM
  5. Why is my S3 saying it is docked but I do not have a dock?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-06-2014, 02:31 PM