1. Cassie Cordova's Avatar
    I recently purchased a Tagital Tablet 9inch for my autistic daughter last month. After a week of having it and using it, working perfectly fine, bright red letters appeared on the screen that say DEMO. I've tried a completely factory reset, which removed everything she downloaded, which sent her into a tantrum and meltdown, and it still didn't work. Went into the settings, found in the display there were DEMO options, yet you cannot select these at all. Tried hard reset. NOTHING WORKS. I am getting so unbelievably irritated. There has got to be someone out there that has had the same damn problem. HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    10-11-2014 12:18 PM
  2. AlfBriggs's Avatar
    Sorry to hear of your problems have you contacted their customer service call them up and demand don't hold back only then will you get what you deserve; the answers! Sometimes tech does this but its not your fault. Maybe visit the shop and complain and ask for a replacement should push come to shove.

    Posted via the Android Central App
    10-11-2014 02:38 PM
  3. hitchens1934's Avatar
    You need to try to upgrade the FIRMWARE. You might have to contact the manufacturer for the means to do this. IT SOLVED THE PROBLEM FOR ME.
    10-15-2014 07:44 AM

Similar Threads

  1. Looking for a 6 inch tablet
    By bwillard92 in forum General News & Discussion
    Replies: 7
    Last Post: 10-14-2014, 03:08 PM
  2. Replies: 2
    Last Post: 10-11-2014, 07:14 PM
  3. Why isn't my audio working?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-11-2014, 04:49 PM
  4. Why can I not connect to my wifi hub?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-11-2014, 03:38 PM
  5. Pre-installed Apps on T-mobile Note 4
    By Closingracer in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 10-11-2014, 12:01 PM