1. AC Question's Avatar
    My Trio Stealth 10 will not work. It keeps saying Unfortunately Google play has stopped, Email has stopped , Google Play services has stopped and so on. It wont let me clear it out. I have tried the reset button and tried holding down the volume and turning on and off
    10-11-2014 07:00 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did the tablet come with Google Play Store preinstalled, or did you have to manually install it yourself? If the latter, that means the device isn't certified for Google Play, and incompatibility may occur.

    Otherwise, are you able to go to Settings>Backup & Reset and select Factory Data Reset?
    10-12-2014 12:14 AM
  3. nathanial gilham's Avatar
    I just bought a trio stealth 10 and I cannot get it to turn on. It has been plugged in for about 12 hours now and still won't turn on. Any suggestions or similar problems?
    Chris Pressley1 likes this.
    01-09-2015 03:09 AM

Similar Threads

  1. How do I delete files from my sd card if it is full?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 01-09-2015, 03:18 AM
  2. My phone wont recognize my SD Card?
    By angrod991 in forum General Help and How To
    Replies: 3
    Last Post: 10-13-2014, 12:50 AM
  3. Replies: 1
    Last Post: 10-11-2014, 08:45 PM
  4. How can I unbrick my Infinix X530?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-11-2014, 07:20 PM