1. cirsina's Avatar
    My home address is outdated in Google Wallet settings so I tried to set a new address. But it keeps saying "Update settings failed. Please try again later." I searched about it on google but few answers came up. Any suggestions?

    PS: I can't change the name either. Everytime I try to save the changes, the failed message pop up with a line of letters and numbers like "W 50598A78C5CB8.A3C9D42.56007B6F" appear on the right top of the page, and the letters and numbers vary every time.
    10-17-2014 01:47 AM
  2. belodion's Avatar
    Welcome to AC☺.

    I'm sorry, I don't understand the problem either but I wonder whether it was a temporary server error or something of the sort. You posted many hours ago....are you still having no success?

    Posted via Android Central App
    10-17-2014 06:07 PM
  3. cirsina's Avatar
    Thank you for your reply.

    No I don't think it a temporary error because this problem persists for several days...
    10-17-2014 07:59 PM
  4. belodion's Avatar
    If you go to Settings, Apps, All, can you scroll to the Google Wallet app? If so, open it and select Clear Cache and Clear Data. Perhaps you will then be able to update your details.
    But get back to us if that doesn't work.

    Posted via Android Central App
    10-18-2014 06:05 AM
  5. cirsina's Avatar
    When changing the settings, the app will guide me to the website. I tried this both on my phone and PC, but neither works.

    Actually it's the Google service's problem, but I don't know where should I go for help...
    10-18-2014 10:19 AM
  6. belodion's Avatar
    If the relevant app is Google Play Services, have you tried clearing cache and data in that?

    Posted via Android Central App
    10-18-2014 08:54 PM
  7. colyn1353's Avatar
    I suspect it was a server issue. I updated my account info a few minutes ago without problems...
    10-18-2014 09:06 PM
  8. Rukbat's Avatar
    Verification doesn't seem to be working today - the Verify button isn't clickable in Firefox.

    Edit: It seems to work fine in Chrome. Thanks, guys, for writing a page that's not cross-browser compatible.
    belodion likes this.
    10-19-2014 04:07 PM

Similar Threads

  1. Why are my phones processes making my phone unusable?
    By ashleyglenn2995 in forum General Help and How To
    Replies: 6
    Last Post: 10-18-2014, 05:50 AM
  2. My s3 from verizon (sch-1535) wont accept any custom recovery
    By Cody Vaughn in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 10
    Last Post: 10-17-2014, 10:50 PM
  3. I finally got my N4 but...
    By Peter McCain in forum Samsung Galaxy Note 4
    Replies: 5
    Last Post: 10-17-2014, 04:32 AM
  4. Anyone having problems with My KNOX?
    By ktopp in forum Samsung Galaxy Note 4
    Replies: 4
    Last Post: 10-17-2014, 04:07 AM