1. Scott Pearce1's Avatar
    When downloading any image from the web, I get a save action to put it in the downloads folder. I can find it in file explorer (3rd party app) the picture will open from there. If i try to use any app to look at the pictures they do not appear. Tried: gallery and photos, both pre-installed on the phone. AND downloaded just pictures as well. The images do not show up at all. Tried three different apps that "Re-scan the device" one of them for root access only. (my phone is rooted) nothing works. sometimes after a day or two the pictures magically appear. Also, the just pictures app has a function to move pictures to another folder. That never works either. Also tried clearing the apps cache, also did not work. Photos will show up in windows explorer when connected to pc.
    10-18-2014 12:03 PM
  2. belodion's Avatar
    Have you got an SD card in the device? If so it may be causing problems.

    Posted via Android Central App
    10-18-2014 08:49 PM

Similar Threads

  1. Can the VM Galaxy S3 be rooted?
    By dacubz in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 10-21-2014, 01:06 PM
  2. Galaxy S3 back-up lost contacts
    By imation in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 10-18-2014, 09:54 PM
  3. How do I turn my Galaxy S3 on if recovery mode fails?
    By brianalcan in forum Ask a Question
    Replies: 2
    Last Post: 10-18-2014, 03:37 PM
  4. How do I get new music from the Google Play store?
    By scozzolino0506 in forum Ask a Question
    Replies: 1
    Last Post: 10-18-2014, 11:08 AM
  5. mobile galaxy s3- all recommended roots not working..
    By daniel scuccimarra in forum T-Mobile Galaxy S III
    Replies: 0
    Last Post: 10-18-2014, 10:58 AM