1. kazilotus's Avatar
    I am really lost and have no clue how to proceed, that's why I joined this forum hoping to find some answers. I have a Samsung Galaxy Tab 2 (7-Inch), 5 months ago I lost the data cable, after a week later I bought a new cable and when i tried to charge it, it doesn't charge. Tried all those button combination stuffs and nothing happened. Later I learned the battery was completely drained and I had to get a new battery but I couldn't find it in any local shop. Today I went through an article regarding kick/jump starting lithium ion batteries. So I opened up the tab using my nail and kitchen knife (It sucked). First I just tried disconnecting and reconnecting the battery connector, It didn't work. So, I disconnected it again and this time I took a ripped of USB cable and connected it to my laptop and the bare black cable to the negative terminal and the red to the positive terminal of the battery. I kept it like that for almost 30-45 Minutes. Then I connected the battery to the tab and then VOILA! It works, it was 49% charged. That was pleasing but when I tried to charge it didn't charge. I tried another cable, tried using the original travel adapter, it didn't work. Seems like the tab doesn't even know it has something hooked up on its underside I m pretty sure the battery is fine; almost after using the tab for 20 minutes the charge dropped from 42% to 41%. So what can I do now ?

    10-22-2014 09:57 PM
  2. Rukbat's Avatar
    The microUSB connector is connected to the motherboard (or daughterboard in phones that have a separate board for the connector) by 5 wire-thin pins. If one of the power pins breaks the solder connection to the board, the device won't charge. (It's nice that all manufacturers [other than Apple] have agreed to use one power connector for almost all portable devices - the microUSB connector was an unfortunate choice. Solder is good for making electrical connections but every soldering course stresses the fact that it shouldn't be counted on for mechanical strength - which it is with a microUSB connector.)) I'm guessing (that's all I can do without having the device in my hands) that one of the pins is loose and has to be resoldered. (Actually all of them should be resoldered, to make sure that none of them break free for a long while.)

    It's why I've gone to Qi charging and wifi file transfer and adb. They don't wear out or come loose.
    10-23-2014 12:11 PM

Similar Threads

  1. Why can't I charge my Nexus 4?
    By DesuCake in forum Google Nexus 4
    Replies: 3
    Last Post: 10-23-2014, 10:44 PM
  2. Galaxy Nexus won't reboot after an update
    By RizaHawkeye in forum Ask a Question
    Replies: 4
    Last Post: 10-23-2014, 10:37 AM
  3. settings tab view/music stutter
    By skippyg in forum Samsung Galaxy Note 4
    Replies: 6
    Last Post: 10-23-2014, 08:33 AM
  4. Can anyone help me get my Galaxy S4 to turn on?
    By whiteeboi in forum Ask a Question
    Replies: 5
    Last Post: 10-23-2014, 02:55 AM
  5. I Have TWRP Installed, but... *Help Please*
    By c419 in forum Verizon Samsung Galaxy Note 3
    Replies: 0
    Last Post: 10-22-2014, 08:25 PM