1. anon9020882's Avatar
    i have tried MANY rooting methods, none have worked... both pc and in android methods... I REALLY NEED TO ROOT THAT PHONE PLS HELP!!. Its a CUBOT GT95 running android 4.4.2 ....
    10-25-2014 03:43 PM
  2. Rukbat's Avatar
    It's an orphan phone, so you'll need a rooting method specifically for that phone, or one that doesn't depend on which phone it's rooting. Try Towel Root (it uses a Linux exploit, so what the manufacturer did to Android doesn't matter. It won't root all 4.4.2 phones, but it won't do any damage if it can't root yours - it;ll just tell you that it can't.)
    10-25-2014 10:17 PM

Similar Threads

  1. Mobile internet has coo123 popup. Anyone know how to fix it?
    By devkhaira in forum Samsung Galaxy S2
    Replies: 16
    Last Post: 06-16-2015, 05:22 PM
  2. Lock screen app that works with fingerprint?
    By sliqx in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 05-19-2015, 07:42 AM
  3. Spigen case doesn't work- mic holes
    By bmoore0909 in forum Samsung Galaxy Note 4
    Replies: 7
    Last Post: 10-26-2014, 09:37 AM
  4. Trying to Flash Stock
    By TOTtomdora in forum Sprint Galaxy S III
    Replies: 1
    Last Post: 10-25-2014, 04:53 PM
  5. How do I install/upgrade a Samsung p500 Tab from 4.1.2 to 4.4?
    By GoTTi in forum Samsung Galaxy Tab 2 10.1
    Replies: 0
    Last Post: 10-25-2014, 02:45 PM