1. Dsk66's Avatar
    My note 4 updated the S Health yesterday and now I'm locked out of the app. Its asking for a password that I don't recall ever having set up. If you enter the wrong password 5 times the screen changes to a "forgot password" screen where I can either "retry" or "reset password" Of course I hit reset and it takes me back to my Samsung app account and asks me the password for that which I readily provide. (note the Samsung app account password didn't work in S Health, I tried!) after successfully providing my password for the Samsung app store, a new screen comes up asking me to enter a password (its basically asking to set up a new password for S Health) which I enter and have to confirm a second time which I do. Now here is the strange part. After resetting my S Health password, I click into the app and try to enter the new password. only for it to say "you have entered an incorrect password. Try again." Really?? rinse and repeat several times and I get the same result. Seems to me Samsung put out a bad update. anyone else?
    10-26-2014 03:14 PM
  2. Dsk66's Avatar
    disregard everything I just said above. I guess it just takes a few minutes because now my password works even though it didn't 8 minutes ago! Patience young padawan!
    10-26-2014 03:22 PM
  3. Mordechai_OShea's Avatar
    I had the same problem this morning, but it didn't go away. I uninstalled the app and when I went into the Galaxy Apps store to try to download it again, it says it is already installed and then I get a "Service Unavailable(2000)" error message. I have absolutely no idea how to reinstall it now. It's definitely not still on the phone. I guess I should have tried the whole patience thing.
    10-26-2014 06:44 PM
  4. Mike Spranger's Avatar
    Same problem here. Haven't reset or changed anything yet. I'll try the patience thing and see how it goes. Starting to hate this phone though.
    10-27-2014 09:00 AM
  5. raysdaman's Avatar
    I'm having the same issue. But waiting hasn't got me anywhere yet. Nor restarting. I'm afraid to Uninstall and reinstall after reading Shea's attempt. Ideas?
    10-27-2014 10:32 AM
  6. shimmy Shamwow's Avatar
    If you are like me and tried to get it to work from the widget, try opening it from the actual app, you might find that you needed to update it. I literally went into panic mode when it for a password. I came in here to look for answers. Hope that helps if any.
    chris5a likes this.
    10-27-2014 11:10 AM
  7. larry0071's Avatar
    Mines locked out. I've tried the reset procedure described above a few times and it has been about 10 minutes. I guess I'll wait a while longer.
    10-27-2014 11:16 AM
  8. Craig Goslan's Avatar
    I went through apps and downloaded it, but it looks very different. It did take up the full width of a home page, now it is the size of an app shortcut (1x1).
    I then took my heart rate several times, readings were mostly just over 100 and one was 54bpm. This app is useless, when my doctor takes my heart rate it is quite normal.
    10-27-2014 04:00 PM
  9. Doc Silva's Avatar
    In my case, the app needed an update. Tap on the app icon, not the widget. I was prompted to update and after, the widget worked without asking for a password.
    10-27-2014 05:37 PM
  10. larry0071's Avatar
    After an hour or so, the reseting the password took hold and it worked.

    But..... I don't want to use a freaking password!
    10-27-2014 06:27 PM
  11. familyguy42's Avatar
    Tap on the app icon, not the widget. I was prompted to update and after, the widget worked without asking for a password. The only annoying thing is that I walked all the way to work before realising this so have lost about 5600 steps data!
    10-28-2014 02:35 AM
  12. lawrenceu88's Avatar
    I am having the same problem as you. Can reinstall the app. Is there any fix to this?

    Posted via the Android Central App
    10-28-2014 01:00 PM
  13. DavidLAX's Avatar
    Similar scenario here. I use the pedometer feature and noticed that the tally of steps stopped appearing on my login screen and that the app stopped working after Oct 26 and begun to prompt me for a password. Like everyone else here I wondered since when is a password needed? I tried the password which I use with the Samsung Owners Hub, but it did not work for S Health. I came here seeking answers and as per the comments in this thread, I did NOT opt to delete the app. Rather, I went to the Apps section, and when I tried to launch S Health there it prompted me to update the app. I did that and then tried to launch it. Once again, it prompted me to update, which I allowed it to a second time. Then it took me thru a series of checkboxes to accept their T&Cs, and then it wonderfully notified me that my previous activity is being accessed and within just a few moments thereafter the app was functioning once again!
    10-31-2014 12:08 PM

Similar Threads

  1. Any suggestion for camera app (replacing ROM camera app)?
    By Punyawee Werasopon in forum LG G3
    Replies: 3
    Last Post: 11-01-2014, 10:23 PM
  2. Is there a way to send and receive texts via email or app?
    By applestreudels in forum General Help and How To
    Replies: 4
    Last Post: 10-27-2014, 12:02 AM
  3. Facebook App Landscape Issues
    By Kcoolby in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 2
    Last Post: 10-26-2014, 10:46 PM
  4. Replies: 1
    Last Post: 10-26-2014, 03:47 PM
  5. No Kids Mode on Samsung Galaxy S4
    By swichelle in forum Ask a Question
    Replies: 0
    Last Post: 10-26-2014, 02:09 PM