1. helpmytech's Avatar
    I am not sure what is wrong with my phone but I suspect a virus, I can not access my google play store and apps on my sd card from my phone (there is one app that I can see from my phone because it is on my phone's memory but when I try to open it, it says "can not start google services try to update and restart your device, but I can not manually update my phone) so I can not install virus protection apps so what programs can I run from my computer to check my phone for viruses? my phone is an LG Connect 4G, MS840.
    10-29-2014 12:45 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I'm not aware of any computer programs that can do that. My guess is that it isn't a virus, unless you've been installing apps directly from suspicious websites (and not from reputable sources like Google Play Store or Amazon Appstore) or clicking on strange popups when browsing. Judging from the error message you mentioned, there might be a problem with Google Play Services. Have you tinkered with the phone at all? Like clearing the data from Google Play Services, or trying to uninstall it?

    Another possibility is a corrupt SD card. Unmount it (in Settings>Storage​), remove it, and reboot to see if you continue to have problems.

    Ultimately, you may need to do a factory reset.
    10-29-2014 06:45 PM
  3. helpmytech's Avatar
    I have tried tinkering with it and I cannot find google play services when I go to manage applications and running services, is there anywhere else I can find it? I do agree that that probably is the issue but I can not find google play which is why I am trying other options and I am really trying to aviod a factory reset.
    10-30-2014 10:44 AM
  4. B. Diddy's Avatar
    Go to Settings>Apps>All, and look for Google Play Services. If it's not there, scroll all the way to the bottom of that list to make sure it isn't Disabled. The current version is 6.1.83.
    10-30-2014 01:23 PM
  5. helpmytech's Avatar
    google play services is missing as well, I'm not sure if the phone shut off during an update and caused this but my andriod version is 2.3.6 I'm not sure if that's the highest for this paricular phone the LG Connect 4G, MS840 or not. and how do I check if google play services is disabled by the way?
    10-30-2014 05:05 PM
  6. B. Diddy's Avatar
    Disabling an app isn't possible in 2.3.6, so that's not possible. Go to this app page for Google Play Services on your computer browser, and see if you can click the Install or Installed button. Then see if you can select your phone for installation.
    10-30-2014 05:22 PM
  7. helpmytech's Avatar
    my current phone is greyed out on the selection and it says "your device already has this item installed"
    10-30-2014 05:48 PM
  8. B. Diddy's Avatar
    I think you may have to try a factory reset.
    10-30-2014 08:08 PM
  9. helpmytech's Avatar
    which is something I would really hate to do, especially if it doesn't solve the problem afterwards.
    10-30-2014 10:33 PM
  10. B. Diddy's Avatar
    Let's take a step back for a second--you said in your original post that you couldn't access your apps on your SD card. Are you saying your apps were installed on the SD card? That is, they were moved from phone storage to SD card? And now you can't access them? If that's the case, perhaps the SD card has become corrupted.
    10-30-2014 10:58 PM
  11. Rukbat's Avatar
    which is something I would really hate to do, especially if it doesn't solve the problem afterwards.
    If you can install Helium (even if the phone isn't rooted, you download a PC program, connect the phone to the PC, and Helium runs), you can back up all your apps and all their data, and there are apps to back up your texts (your contacts should be backed up on Google Contacts and your emails are on the email server), so a factory reset won't be as traumatic as "I lose everything", it'll just be "I'll lose a couple of hours".
    10-30-2014 11:01 PM
  12. helpmytech's Avatar
    yes the apps are on my sd card but they were not moved to my phone storage, when I connect my phone to the computer and look at my sd card from there it shows that the apps are still on the sd card. There was one app orginally installed on my phone that is still there but when I try to open it I receive the "can not start google services try to update and restart your device" message.
    10-31-2014 10:37 AM
  13. B. Diddy's Avatar
    Which app on your phone storage are you trying to open? Is it a Google app?

    Do you still have the Play Store icon in your App Drawer? What happens when you tap it? Do you get an error message, or does it just not do anything?
    10-31-2014 11:15 AM
  14. helpmytech's Avatar
    it's an app called lift no it's not a google app. The play store is completely missing from my app drawer
    10-31-2014 03:48 PM
  15. B. Diddy's Avatar
    Sorry, I don't have anything else to suggest besides a factory reset. I'm not sure how your phone got that messed up ...
    10-31-2014 05:24 PM
  16. helpmytech's Avatar
    thanks for giving it a shot
    10-31-2014 08:54 PM
  17. helpmytech's Avatar
    that sounds good where can I install this program?
    11-02-2014 09:36 PM
  18. B. Diddy's Avatar
    Are you asking about Helium?
    11-02-2014 11:01 PM
  19. helpmytech's Avatar
    11-03-2014 09:32 AM
  20. B. Diddy's Avatar
    I linked it in the above post.
    11-03-2014 10:43 AM

Similar Threads

  1. Change D855 to a D851?
    By stardomains in forum LG G3
    Replies: 6
    Last Post: 01-08-2016, 07:03 AM
  2. Replies: 8
    Last Post: 11-04-2014, 11:59 PM
  3. Looking forward to the Smartwatch 3...
    By reesh11 in forum Sony Smartwatches
    Replies: 14
    Last Post: 11-03-2014, 07:12 PM
  4. URGENT! Someone is hacking my phone!
    By Valentina Paris in forum HTC One Mini 2
    Replies: 4
    Last Post: 10-29-2014, 01:50 PM