1. Itisjames's Avatar
    Hi all,

    I'm having an issue connecting to any of Google's applications (Play Store, Play Books/Music, Gmail, Adsense, etc.) With the exception of Chrome, which is loading fine.

    My phone was previously rooted with Towelroot, but since then the root was removed with an OTA update by AT&T. I started getting the issue around then, but I'm not sure if it caused by that itself.

    I've done a hard reset of the phone, and I'm still having the same problem. I can't even open the Play Store at all now, as it wants me to connect a Google account.
    My phone is essentially unusable at this point as I no longer have any apps on it, and I'm unable to download them from the Play Store in a browser either.

    So far I have tried removing cache, resetting the date and time (automatic and manual), uninstalling updates (before factory reset) and a full reset of the phone. Nothing has worked.

    I have checked other threads and the only solution I've found that I haven't already tried is modifying the hosts file, but I can't access that because my phone isn't rooted.

    The problem persists on both my WI-FI and data conection, so I know it's not that.

    This is my first Android phone so perhaps there's something obvious I'm missing. I'm a recent convert from iPhone, and I really want to love this phone, but I've had nothing but problems so far

    Any help would be appreciated, thank you.
    11-01-2014 12:06 PM
  2. Rukbat's Avatar
    Have you checked to make sure, in Settings/Accounts/Google, that your Google account is there and correct? Without that, Google doesn't know your phone, and you're asked to log in - which doesn't work because Google has a bad link there.

    As for the hosts file, that''s only if you know a link is bad and you know the correct one - and the app is going to the link by name, not by address. Then you can put the correct address for that name in the file. (You can also make your phone the "correct" address for sites you don't want your phone to go to - that's how a lot of ad blockers work.)

    If your account is correct in the phone, take it to your nearest AT&T Device Support Center (ask at your local store - it may be there, or at some other nearby store). They should be able to get you fixed up. (The phone is still in warranty - just make sure all signs of root - like SuperSU - are gone.)
    11-01-2014 02:16 PM

Similar Threads

  1. How do I fix my hacked galaxy S5?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 07-27-2015, 05:28 PM
  2. Replies: 7
    Last Post: 11-09-2014, 12:50 AM
  3. Why can't I find the URL on my Galaxy S5?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2014, 02:29 PM
  4. cant sent text to one contact
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2014, 02:27 PM
  5. Replies: 0
    Last Post: 11-01-2014, 11:54 AM