1. AC Question's Avatar
    Hi, today my phone has decided that when I turn it on it gets stuck on the samsung logo and won't boot any further. I have tried putting my phone in recover mode and clearing cache which didn't work and nor did restoring the phone to factory settings. My model is GT-I9300.

    Can anyone shed some light on what I need to do to get it working again?

    Another thing- when it was in recover mode I noticed the (in red writing) 'E: failed to mount /system (argument invalid) was displayed. And when I plugged my phone into my laptop and opened up it's properties it came up with 'Kurio7s', which I thought was wired and when I googled it apparently its some type of childrens tablet device?

    Finally- when I just charge the phone no blue light is shown to show it is charging and also- the empty battery symbol stays empty with the white circle not rotating?

    Please can someone held my solve this, I'm not very tech savvy so can any jargon be explained.

    Thank you!
    11-01-2014 02:48 PM
  2. Golfdriver97's Avatar
    Welcome to the forums. Have you tried a factory reset when you are in recovery?

    Sent from an AOSP M8
    11-01-2014 04:44 PM

Similar Threads

  1. Galaxy Note 4 headphones?
    By davidadams3 in forum Samsung Galaxy Note 4 Accessories
    Replies: 5
    Last Post: 11-04-2014, 10:42 PM
  2. The Future looks bright for Moto and Droid owners
    By Firedogee in forum Motorola Droid Turbo
    Replies: 7
    Last Post: 11-01-2014, 03:48 PM
  3. Replies: 2
    Last Post: 11-01-2014, 03:19 PM
  4. Replies: 1
    Last Post: 11-01-2014, 02:56 PM