1. AC Question's Avatar
    I would like to be able to use my camera again on my Galaxy Centura (Straight Talk). Here is how I encounter the problem:

    1. I select Camera from my app menu
    2. device brings me to a blank (black) screen, with button, camera/video selection, and last picture taken menu visible at the "bottom" of the screen (depending on the orientation of the phone)
    3. I check to see if the lens is blocked or dirty; it is neither
    4. I click on the shutter button - error message appears: Camera error Can't connect to the camera. I click ok.

    5. I select Settings from my app menu, then select Apps
    6. I choose "All" then "Camera"
    7. My cache is at 0.00 percent (I cleared it about 24 hours ago, right before I noticed this problem). The readouts are as follows: Total: 64.00KB; App: 0.00B; USB storage app: 0.00B; Data: 64.00KB; SD card: 0.00B.

    I am hesitant to clear Data because I do not want to lose my pictures; I am in the process of running them off tonight, so I can do whatever is needed to fix this problem.

    Clearing my cache to fix this problem won't work, it is already at 0.00.

    The camera is "version 1"

    Thanks in advance for your help!
    11-01-2014 06:35 PM
  2. belodion's Avatar
    You won't lose your photos if you select Clear Data.
    Possibly some third-party app with permission to use Camera is the cause of the trouble....can you think of any that you have installed that may be the likely culprit?

    Posted via the Android Central App
    Niamhfield11 likes this.
    11-01-2014 06:39 PM
  3. Niamhfield11's Avatar
    Everytime i click on my camera its saying camera failed its so irritating as its stoping me from using any apps or taking any picture ! I have tried everything i hav deketed apps cleared my phone and reset it and nothing its heling
    09-12-2015 01:49 PM
  4. belodion's Avatar
    Welcome to Android Central.

    Try Safe Mode, which will test whether a third-party app is causing trouble.
    Otherwise, there may be a fault with the camera, or possibly with the software.

    Posted via the Android Central App
    09-12-2015 05:53 PM
  5. Julialehman's Avatar
    So, the thing that is happening up here is also happening with the camera on my LG tablet. I've tried to clear the data and reset everything, but nothing has worked. I however have not tried to use the Safe Mode because I don't know how to activate it. How do I activate it, and if it does not work, what should I do?
    04-08-2016 03:08 PM
  6. vinod sharma6's Avatar
    My Samsung galaxy grand prime camera is not working
    08-02-2016 11:05 AM
  7. B. Diddy's Avatar
    Welcome to Android Central! Give us more details, and if you already tried what was mentioned above.
    08-02-2016 12:10 PM
  8. Maylani's Avatar
    I have a new Samsung Galaxy 7 edge and my camera went blank?? What can I do
    11-08-2016 12:51 PM
  9. 1pete's Avatar
    Hi I have an old Samsung galaxy s2 (yeh its old) but its rarely used only for pics etc when I go on holidays. Its never been dropped or anything and for some reason my camera wont work. I've looked at places that say what to do when it says camera failed and have tried going to application manager,clicking on camera, force stop n clear data, then restarted camera. And it still says camera failed?? The version is 1.5.. Is there any way that i can get it working? By new update or app or whatever??? Please help as I dont want a new phone as I hardly use it.. Thanks
    01-09-2017 08:52 PM
  10. isabear's Avatar
    I just restarted my phone not worrying and everything was fine after that.
    01-13-2017 09:31 PM
  11. Aleksonfire's Avatar
    Ok I finally found a solution to the same issue and haven't seen anyone else mention doing the same thing. So maybe it will help all those people trying to figure it out that were just as frustrated at the lack of an answer.

    Apparently when formatting the sd card to work as internal it ****ed up my dcim folder and can no longer read or write to it. So using file manager I browsed to my dcim folder. Copy and pasted what was in there to another folder. I then deleted it. The system created a dcim folder with a bunch of numbers attached.(note:tried deleting it too but cant seem to get rid of it).
    Next i cleared the data on the camera app under system settings. (Not cache but actual data)
    This created a new Dcim folder and then let the camera operate normally.

    Hopefully it helps.

    Easy Step by step.
    1. Open file manager and find DCIM folder on sd card.
    2. Copy and paste if you want to save whats in it to any folder.
    3. Delete DCIM folder
    4. Go to apps, and find camera, and then clear DATA
    5. Open Camera and give normal permissions, and then should work properly.
    belodion likes this.
    06-11-2017 02:02 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-01-2014, 11:31 PM
  2. How do I retreive old text messages that my phone deletes?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2014, 08:04 PM
  3. Will there be another Nexus 4 phone made by Google?
    By ufobase in forum Ask a Question
    Replies: 3
    Last Post: 11-01-2014, 07:06 PM
  4. Replies: 1
    Last Post: 11-01-2014, 06:54 PM
  5. Samsung Galaxy Note 4 Camera modes
    By PhilNUK in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 11-01-2014, 06:37 PM