1. Mariseboy25's Avatar
    My phone was soft bricked so I tried to unbrick it, I had it on download mode but Odin wasn't recognising my phone so I took the phone off to try again tomorrow. I tried again and Odin recognised my phone and I flashed a rom to unbrick the phone however when it rebooted it still doesn't work. I tried to go on recovery mode and factory reset it and wipe cache partition and reboot but it still doesn't work. What do I do?
    11-04-2014 03:01 PM
  2. Rukbat's Avatar
    Are you sure that the ROM file you flashed was for your country/carrier? There are 50 of them at SamMobile. The wrong file won't work.
    11-04-2014 05:20 PM
  3. Mariseboy25's Avatar
    Yes it was O2 Samsung Galaxy Ace S5830i, I'm pretty sure, I will try again then and see if it works?
    11-05-2014 01:42 PM
  4. Rukbat's Avatar
    If it doesn't, download it again and try. It's not likely, but it's possible to get a bad download.
    11-05-2014 04:01 PM

Similar Threads

  1. Samsung Gear S arrival in Saint Louis Metro area now
    By Dante314 in forum Samsung Gear S
    Replies: 51
    Last Post: 11-06-2014, 02:10 PM
  2. lines on screen when looking at photos
    By biggunspaul in forum Samsung Galaxy Note 4
    Replies: 15
    Last Post: 11-05-2014, 02:25 PM
  3. Water damage to my Galaxy S3, but its not turning on?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 11-04-2014, 11:14 PM
  4. my phone gs4 was on op to 50% is this normal
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-04-2014, 03:36 PM