1. zlesar's Avatar
    I have tried every solution i could find on forums, but google play is still crashing. I thought that is going to work now, but when I tried to update app (this happened to me a few times, always tried to update one app a time, each time diffrent app) it says downloading a few seconds then crash. And then when I try to re open google play it gives erroe straight away. this is error report:

    java.lang.SecurityException: Invalid value for is_public_api: null ----> changed after some trying to:java.lang.SecurityException: Invalid columns in request: cookiedataotheruidnotificationclass
    at android.os.Parcel.readException(Parcel.java:1472)
    at android.database.DatabaseUtils.readExceptionFromPa rcel(DatabaseUtils.java:185)
    at android.database.DatabaseUtils.readExceptionFromPa rcel(DatabaseUtils.java:137)
    at android.content.ContentProviderProxy.insert(Conten tProviderNative.java:475)
    at android.content.ContentResolver.insert(ContentReso lver.java:1190)
    at com.google.android.finsky.download.DownloadManager LegacyImpl$2.run(DownloadManagerLegacyImpl.java:17 7)
    at android.os.Handler.handleCallback(Handler.java:733 )
    at android.os.Handler.dispatchMessage(Handler.java:95 )
    at android.os.Looper.loop(Looper.java:136)
    at android.os.HandlerThread.run(HandlerThread.java:61 )

    I have been working on this a few days now and no luck. Any help where appreciete. (Sry for bad english and spelling)
    11-21-2014 11:39 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! What device do you have? It would also help to know what you've tried, because otherwise, people may just assume that you've tried what they might suggest, and not bother to reply.

    Things I usually suggest are:

    1. Go to Settings>Apps>All, select Google Play Store, and Force Stop, then Clear Cache/Clear Data.
    2. Do the same for Download Manager (and make sure Download Manager is not Disabled).
    3. Remove your Google account in Settings>Accounts, then add it back again.
    4. A system cache partition wipe (if possible on your device).

    If all else fails, try a factory data reset.
    wizzrah likes this.
    11-22-2014 01:19 AM

Similar Threads

  1. Replies: 3
    Last Post: 12-01-2014, 05:52 PM
  2. Replies: 4
    Last Post: 11-21-2014, 04:38 PM
  3. Replies: 4
    Last Post: 11-21-2014, 11:19 AM
  4. Google Now Cards showing random images.
    By HazMatt55 in forum Legacy Android & Other OS's
    Replies: 3
    Last Post: 11-21-2014, 10:52 AM
  5. Replies: 1
    Last Post: 11-21-2014, 09:54 AM