1. terry gage's Avatar
    keep getting error report RPC:S-7:AEC-7. This applies to updates & downloads.
    In particular I am trying to download Chromecast.
    What to do to get it to happen. I have tried clearing data in App. Manager
    11-23-2014 12:55 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to the App Manager, select Google Play Store, and Clear Cache/Data, then Force Stop. Do the same for Download Manager.

    If that doesn't help, go to Settings>Accounts, and remove your Google account completely, then add it back again.
    11-23-2014 01:52 AM
  3. wizzrah's Avatar
    I read on a T-Mobile forum post about a person getting the same error fixing the problem with a software update. See if there is any for your device.
    However, clearing the cache and data for the play store app fixed the problem for another.


    11-23-2014 02:22 AM

Similar Threads

  1. Google Play Services Update
    By Benjamin_NYC in forum Google Nexus 6
    Replies: 44
    Last Post: 12-01-2014, 07:09 AM
  2. Can I take the sim out of my Maxx and put it in the turbo?
    By arandomgecko in forum Motorola Droid Turbo
    Replies: 11
    Last Post: 11-24-2014, 01:13 PM
  3. Sprint Profile / prl update.
    By dkjames71 in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 11-23-2014, 04:59 PM
  4. Note pro wifi issue.
    By elvyb in forum Samsung Galaxy Note Pro 12.2
    Replies: 1
    Last Post: 11-23-2014, 01:59 AM
  5. Why won't my Note 4 download or update some apps?
    By terry gage in forum Ask a Question
    Replies: 1
    Last Post: 11-23-2014, 12:27 AM