1. ja289's Avatar
    I have a Motorola moto X. Not the new Chinese one, the USA one. I have had it since April. My home wifi has worked fine until a couple days ago. It just quit working. My laptop, my wife's phone (also a moto X) and her tablet all still work on the wifi. I turned off the wep security so I don't have to enter that 100 more times while I'm trying to figure this out. I have reset the router and rebooted the phone several times to no avail. I hit connect and it says connected with a full wifi signal. Within about 2 seconds it disconnects. I haven't tried it on another wifi yet as this is the only one I'm around this week. My mobile internet works fine. Is it my phone or a router problem? Any help would be great.
    11-25-2014 07:12 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Review this guide and see if there are any tips you haven't tried yet: http://forums.androidcentral.com/amb...-problems.html
    11-26-2014 12:59 AM
  3. ja289's Avatar
    I tried all of those. My phone works on other wifi routers, just not my home wifi. 3 other devices work on my home wifi. What could it be?
    11-28-2014 11:29 AM
  4. B. Diddy's Avatar
    When you say you reset your router, did you do a full factory reset? Check the manual to see how to do it, since that's with trying.

    What brand is the router? And what Android version are you running? I've read that Lollipop is causing problems with Cisco routers.

    Posted via Android Central App
    11-28-2014 12:16 PM
  5. Rukbat's Avatar
    When you say you reset your router, did you do a full factory reset?
    30-30-30 usually hard resets all routers.

    1) Hold in the reset button for 30 seconds (use a timer or watch the clock.)
    2) Keeping the reset button pushed, remove the power plug from the router.
    3) After the power plug has been out for 30 seconds, keeping the reset button pushed, plug the power in again.

    After the holding the reset button pushed for 30 seconds let go of the reset button and the router should be at factory settings.

    To the OP:
    Since your wife's phone, your laptop and your tab all work, your router is working. I would mention that 802.11N doesn't support WEP (the devices have to connect using G) but you said that you took security off, so that wouldn't be the problem. I'd suspect a bad phone.
    B. Diddy likes this.
    11-28-2014 02:40 PM
  6. ja289's Avatar
    I really don't know what android I have or what lollipop is. I did the 30 30 30 reset and it turned my wep back on. It still connects then instantly disconnects like before. It is the router the Frontier phone company put in. It says Frontier on the front and Westell on the back. I don't think it is my phone because it works on three other wifi routers but I don't think its my router because it works on all the other devices. I am stumped.
    11-30-2014 11:15 PM
  7. Rukbat's Avatar
    I've come to the conclusion that not all phone manufacturers and not all router manufacturers consider 802.11 a standard, but more of a suggestion, and some phones aren't compatible with some routers. I can connect to my router, but the speed on some apps stinks. But on an old router (VERY old), it connects and the speed is fine. And with a barely usable signal in the parking lot of a store with public wifi I also get good speed.

    Some day people will learn what "standard" really means. 9 pin "RS-232" connectors (the standard specifies a 25 pin connector), the QIC committee's standards implemented so badly that a tape written on one machine couldn't be read on another machine of the same model from the same manufacturer ... It's been going on as long as I've been in the industry, and that's about half a century.
    11-30-2014 11:46 PM
  8. B. Diddy's Avatar
    I really don't know what android I have or what lollipop is.
    To find out your Android version, go to Settings>About Phone>Android Version. Lollipop is the nickname for Android 5.0. KitKat is the nickname for Android 4.4.
    12-01-2014 12:08 AM
  9. ja289's Avatar
    OK, it says android 4.4.4 so I guess that's KitKat. The phone DID work on the router then all of a sudden quit so it was compatible with the router. I am typing this right now on my phone through a different router so the phone works. I'd just really like to be able to connect at home, especially since I don't have any service there. I guess I just have to give up. I can figure out any mechanical problem, but I'm not very good with the computer stuff.

    Thanks for the help.
    12-03-2014 12:48 PM
  10. Rukbat's Avatar
    I had a similar problem - low speed on a top of the line Linksys router - only with my Note 4s - unless I used the guest account. I solved it for $45 - I bought a bottom of the line Netgear router - model N300. I just set it up the same - same name (SSID), same router password, same wifi password. Everything connected as if I had just turned the router off for a few minutes. Full speed and no hiccups.

    For years my method was Linksys for home or small office use, Cisco for large company use. If I were still doing the work I'd start seeing what Netgear has, how easy they are to deal with (I haven't had to call them), etc. Considering the total lack of interest in the fact that they've made routers that are incompatible with cellphones, I think Linksys/Cisco is going to start losing a lot of customers. (People like us, using a router at home, can kill a weekend trying to make the router work. When you're doing it for a customer, it's plug the wires in, turn it on, set it up, and it better be working. If it takes more than 5 minutes after that you're losing money, so you don't buy that manufacturer's products again when their response amounts to a yawn and an attitude of "we got your money, so we don't care" - which is what a few people [myself included] have gotten from Linksys.)
    12-03-2014 02:24 PM
  11. B. Diddy's Avatar
    For what it's worth, I've had zero problems with my D-Link router, in case you're looking for another brand to try.
    12-03-2014 11:53 PM
  12. ja289's Avatar
    I have a little more information. My phone works on any WiFi except a frontier router. I tried it on another frontier router and it does the same thing as my home router. Now I know it's definitely my phone. Is there some setting that got switched on it?
    12-10-2014 12:40 PM

Similar Threads

  1. Connected, running sync loop???
    By ezzzzz in forum Android Wear / Wear OS
    Replies: 4
    Last Post: 11-27-2014, 07:07 PM
  2. Replies: 2
    Last Post: 11-26-2014, 06:50 AM
  3. Can I use a Verizon branded phone for wifi calls only?
    By Bob McCall in forum Ask a Question
    Replies: 2
    Last Post: 11-25-2014, 05:51 PM
  4. Why won't my phone work after replacing sim card.
    By thiskatbites in forum T-Mobile Galaxy S III
    Replies: 1
    Last Post: 11-25-2014, 03:22 PM
  5. Replies: 1
    Last Post: 11-25-2014, 12:46 PM