1. Guedoe's Avatar
    My grandfather was issued a Verizon galaxy tab 2 to help with reporting health conditions to his doctor. Now that he is in home care, it is not needed. When you turn it on the Samsung logo appears, galaxy tab 2 logo appears, and then the Verizon logo. Once done you never see the home page. There is an app that automatically starts. You can't back out of it or anything. Tried factory reset, same thing. Tried to flash several times but "SECURE CHECK FAIL : recovery". There is no way to get into the settings to set the usb debugging. Is this thing dead to me?
    11-29-2014 07:11 PM
  2. Rukbat's Avatar
    It's possible. Try to boot into download mode (Volume Down/Home/Power. If it does, don't let the "don't turn the phone off" thing scare you - you can turn it off. But in that mode you can flash a stock Verizon ROM for that model S2 (the model number is on the label under the battery). SamMobile Firmwares should have a ROM for it. The worst that can happen is that a now-useless phone becomes useless.
    11-29-2014 08:20 PM
  3. Guedoe's Avatar
    Wow, thanks. SamMobile had the perfect version. This thing is good to go
    11-29-2014 11:22 PM

Similar Threads

  1. Why aren't my app icons showing up after installed?
    By jallenaz in forum Samsung Galaxy Tab S 10.5
    Replies: 25
    Last Post: 08-09-2017, 05:47 PM
  2. Why are my calls being dropped?
    By mmsayeed in forum Samsung Galaxy Note 4
    Replies: 6
    Last Post: 12-02-2014, 05:02 PM
  3. Problem with Textra App?
    By Nicole Kala in forum Ask a Question
    Replies: 2
    Last Post: 11-30-2014, 04:21 PM
  4. Replies: 3
    Last Post: 11-30-2014, 01:19 PM
  5. Switching between normal and vibrate on the lock screen
    By tmcmack in forum Motorola Droid Turbo
    Replies: 3
    Last Post: 11-30-2014, 06:06 AM
LINK TO POST COPIED TO CLIPBOARD