1. Tataman's Avatar

    I received a firmware update notification in my Samsung S4, so I downloaded and accept to install. The problem is that it says that there is an error at the end of the installation, the phone restarts, goes to "Recovery booting..." and start the process again... and again and again. I've tried taking the battery out but it restart in recovery. Then I tried to go to recovery and download mode and it didn't work neither.
    I have never rooted or modified my phone...
    How can I solve this???

    Thank you very much guys!
    11-29-2014 08:44 PM

Similar Threads

  1. Why are my calls being dropped?
    By mmsayeed in forum Samsung Galaxy Note 4
    Replies: 6
    Last Post: 12-02-2014, 05:02 PM
  2. Replies: 3
    Last Post: 11-30-2014, 01:19 PM
  3. How do I reset my Tablet to factory settings?
    By Guedoe in forum Ask a Question
    Replies: 2
    Last Post: 11-29-2014, 11:22 PM
  4. Replies: 1
    Last Post: 11-29-2014, 05:56 PM
  5. Why won't my Galaxy S2 go to home screen?
    By hgu1 in forum Samsung Galaxy S2
    Replies: 1
    Last Post: 11-29-2014, 04:43 PM